Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:2121-1: moderate: Security update for iperf
openSUSE Security Update: Security update for iperf
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2121-1
Rating: moderate
References: #984453
Cross-References: CVE-2016-4303
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

iperf was updated to the the following vulnerability:

- CVE-2016-4303: A malicious client could have triggered a buffer overflow
/ heap corruption issue by sending a specially crafted JSON string, and
possibly execute arbitrary code (boo#984453)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1006=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-1006=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

iperf-3.0.12-5.1
iperf-debuginfo-3.0.12-5.1
iperf-debugsource-3.0.12-5.1
iperf-devel-3.0.12-5.1
libiperf0-3.0.12-5.1
libiperf0-debuginfo-3.0.12-5.1

- openSUSE 13.2 (i586 x86_64):

iperf-3.0.12-2.6.1
iperf-debuginfo-3.0.12-2.6.1
iperf-debugsource-3.0.12-2.6.1
iperf-devel-3.0.12-2.6.1
libiperf0-3.0.12-2.6.1
libiperf0-debuginfo-3.0.12-2.6.1


References:

https://www.suse.com/security/cve/CVE-2016-4303.html
https://bugzilla.suse.com/984453


< Previous Next >
This Thread
  • No further messages