Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:2109-1: moderate: Security update for roundcubemail
openSUSE Security Update: Security update for roundcubemail
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2109-1
Rating: moderate
References: #976988
Cross-References: CVE-2015-2181 CVE-2015-8864 CVE-2016-4069

Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for roundcubemail fixes the following vulnerabilities:

- CVE-2015-8864: XSS issue in SVG images handling (boo#976988)
- CVE-2015-2181: issue in DBMail driver of password plugin
- CVE-2016-4069: Cross-site request forgery in download URLs (boo#976988)

Roundcubemail was also updated to 1.1.5, fixing the following bugs:

- Plugin API: Add html2text hook
- Plugin API: Added addressbook_export hook
- Fix missing emoticons on html-to-text conversion
- Fix random "access to this resource is secured against CSRF" message at
logout
- Fix missing language name in "Add to Dictionary" request in HTML mode
- Enable use of TLSv1.1 and TLSv1.2 for IMAP
- Fix bug where Archive/Junk buttons were not active after page jump with
select=all mode
- Fix bug in long recipients list parsing for cases where recipient name
contained @-char
- Fix additional_message_headers plugin compatibility with Mail_Mime >= 1.9
- Hide DSN option in Preferences when smtp_server is not used
- newmail_notifier: Refactor desktop notifications
- Fix so contactlist_fields option can be set via config file
- Fix so SPECIAL-USE assignments are forced only until user sets special
folders
- Fix performance in reverting order of THREAD result
- Fix converting mail addresses with @www. into mailto links


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-995=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (noarch):

roundcubemail-1.1.5-9.1


References:

https://www.suse.com/security/cve/CVE-2015-2181.html
https://www.suse.com/security/cve/CVE-2015-8864.html
https://www.suse.com/security/cve/CVE-2016-4069.html
https://bugzilla.suse.com/976988


< Previous Next >
This Thread
  • No further messages