Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:1977-1: moderate: Security update for bsdiff
openSUSE Security Update: Security update for bsdiff
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1977-1
Rating: moderate
References: #990660
Cross-References: CVE-2014-9862
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for bsdiff fixes the following issues:

- CVE-2014-9862: Improper checking of input allows arbitrary write on heap
(boo#990660)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-946=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-946=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

bsdiff-4.3-9.2

- openSUSE 13.2 (i586 x86_64):

bsdiff-4.3-2.5.2


References:

https://www.suse.com/security/cve/CVE-2014-9862.html
https://bugzilla.suse.com/990660


< Previous Next >
This Thread
  • No further messages