Mailinglist Archive: opensuse-updates (99 mails)

< Previous Next >
openSUSE-SU-2016:1843-1: moderate: Security update for dhcp
openSUSE Security Update: Security update for dhcp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1843-1
Rating: moderate
References: #969820 #972907
Cross-References: CVE-2016-2774
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


This update for dhcp fixes the following issues:

Security issue fixed:
- CVE-2016-2774: Fixed a denial of service attack against the DHCP server
over the OMAPI TCP socket, which could be used by network adjacent
attackers to make the DHCP server non-functional (bsc#969820).

Non security issues fixed:
- Rename freeaddrinfo(), getaddrinfo() and getnameinfo() in the internal
libirs library that does not consider /etc/hosts and /etc/nsswitch.conf
to use irs_ prefix. This prevents name conflicts which would result in
overriding standard glibc functions used by libldap. (bsc#972907)

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-887=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

dhcp-4.3.3-7.1
dhcp-client-4.3.3-7.1
dhcp-client-debuginfo-4.3.3-7.1
dhcp-debuginfo-4.3.3-7.1
dhcp-debugsource-4.3.3-7.1
dhcp-devel-4.3.3-7.1
dhcp-doc-4.3.3-7.1
dhcp-relay-4.3.3-7.1
dhcp-relay-debuginfo-4.3.3-7.1
dhcp-server-4.3.3-7.1
dhcp-server-debuginfo-4.3.3-7.1


References:

https://www.suse.com/security/cve/CVE-2016-2774.html
https://bugzilla.suse.com/969820
https://bugzilla.suse.com/972907


< Previous Next >
This Thread
  • No further messages