Mailinglist Archive: opensuse-updates (99 mails)

< Previous Next >
openSUSE-SU-2016:1834-1: moderate: Security update for nodejs
openSUSE Security Update: Security update for nodejs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1834-1
Rating: moderate
References: #987919
Cross-References: CVE-2016-1669
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for nodejs fixes the following issue:

- CVE-2016-1669:
* fix buffer overflow in v8 (boo#987919)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-884=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-884=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

nodejs-4.4.5-30.2
nodejs-debuginfo-4.4.5-30.2
nodejs-debugsource-4.4.5-30.2
nodejs-devel-4.4.5-30.2
npm-4.4.5-30.2

- openSUSE Leap 42.1 (noarch):

nodejs-docs-4.4.5-30.2

- openSUSE 13.2 (i586 x86_64):

nodejs-4.4.5-21.1
nodejs-debuginfo-4.4.5-21.1
nodejs-debugsource-4.4.5-21.1
nodejs-devel-4.4.5-21.1

- openSUSE 13.2 (noarch):

nodejs-doc-4.4.5-21.1


References:

https://www.suse.com/security/cve/CVE-2016-1669.html
https://bugzilla.suse.com/987919


< Previous Next >
This Thread
  • No further messages