Mailinglist Archive: opensuse-updates (99 mails)

< Previous Next >
openSUSE-SU-2016:1727-1: moderate: Security update for gimp
openSUSE Security Update: Security update for gimp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1727-1
Rating: moderate
References: #986021
Cross-References: CVE-2016-4994
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

gimp was updated to version 2.8.16 to fix one security issue.

This security issue was fixed:
- CVE-2016-4994: Use-after-free vulnerabilities in the channel and layer
properties parsing process (bsc#986021).

This non-security issues were fixed:
- Core:
* Seek much less when writing XCF
* Don't seek past the end of the file when writing XCF
* Fix velocity parameter on .GIH brushes
* Fix brokenness while transforming certain sets of linked layers
- GUI:
* Always show image tabs in single window mode
* Fix switching of dock tabs by DND hovering
* Don't make the scroll area for tags too small
* Fixed a crash in the save dialog
* Fix issue where ruler updates made things very slow on Windows
-Plug-ins:
* Fix several issues in the BMP plug-in
* Make Gfig work with the new brush size behavior again
* Fix font export in the PDF plug-in
* Support layer groups in OpenRaster files
* Fix loading of PSD files with layer groups


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-822=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-822=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

gimp-2.8.16-4.1
gimp-debuginfo-2.8.16-4.1
gimp-debugsource-2.8.16-4.1
gimp-devel-2.8.16-4.1
gimp-devel-debuginfo-2.8.16-4.1
gimp-help-browser-2.8.16-4.1
gimp-help-browser-debuginfo-2.8.16-4.1
gimp-plugin-aa-2.8.16-4.1
gimp-plugin-aa-debuginfo-2.8.16-4.1
gimp-plugins-python-2.8.16-4.1
gimp-plugins-python-debuginfo-2.8.16-4.1
libgimp-2_0-0-2.8.16-4.1
libgimp-2_0-0-debuginfo-2.8.16-4.1
libgimpui-2_0-0-2.8.16-4.1
libgimpui-2_0-0-debuginfo-2.8.16-4.1

- openSUSE Leap 42.1 (x86_64):

libgimp-2_0-0-32bit-2.8.16-4.1
libgimp-2_0-0-debuginfo-32bit-2.8.16-4.1
libgimpui-2_0-0-32bit-2.8.16-4.1
libgimpui-2_0-0-debuginfo-32bit-2.8.16-4.1

- openSUSE Leap 42.1 (noarch):

gimp-lang-2.8.16-4.1

- openSUSE 13.2 (i586 x86_64):

gimp-2.8.16-3.1
gimp-debuginfo-2.8.16-3.1
gimp-debugsource-2.8.16-3.1
gimp-devel-2.8.16-3.1
gimp-devel-debuginfo-2.8.16-3.1
gimp-help-browser-2.8.16-3.1
gimp-help-browser-debuginfo-2.8.16-3.1
gimp-plugin-aa-2.8.16-3.1
gimp-plugin-aa-debuginfo-2.8.16-3.1
gimp-plugins-python-2.8.16-3.1
gimp-plugins-python-debuginfo-2.8.16-3.1
libgimp-2_0-0-2.8.16-3.1
libgimp-2_0-0-debuginfo-2.8.16-3.1
libgimpui-2_0-0-2.8.16-3.1
libgimpui-2_0-0-debuginfo-2.8.16-3.1

- openSUSE 13.2 (x86_64):

libgimp-2_0-0-32bit-2.8.16-3.1
libgimp-2_0-0-debuginfo-32bit-2.8.16-3.1
libgimpui-2_0-0-32bit-2.8.16-3.1
libgimpui-2_0-0-debuginfo-32bit-2.8.16-3.1

- openSUSE 13.2 (noarch):

gimp-lang-2.8.16-3.1


References:

https://www.suse.com/security/cve/CVE-2016-4994.html
https://bugzilla.suse.com/986021


< Previous Next >
This Thread
  • No further messages