Mailinglist Archive: opensuse-updates (99 mails)

< Previous Next >
openSUSE-SU-2016:1725-1: moderate: Security update for spice
openSUSE Security Update: Security update for spice
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1725-1
Rating: moderate
References: #982385 #982386
Cross-References: CVE-2016-0749 CVE-2016-2150
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

spice was updated to fix two security issues.

These security issues were fixed:
- CVE-2016-2150: SPICE allowed local guest OS users to read from or write
to arbitrary host memory locations via crafted primary surface
parameters, a similar issue to CVE-2015-5261 (boo#982385).
- CVE-2016-0749: The smartcard interaction in SPICE allowed remote
attackers to cause a denial of service (QEMU-KVM process crash) or
possibly execute arbitrary code via vectors related to connecting to a
guest VM, which triggers a heap-based buffer overflow (boo#982385).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-823=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libspice-server-devel-0.12.4-4.12.1
libspice-server1-0.12.4-4.12.1
libspice-server1-debuginfo-0.12.4-4.12.1
spice-client-0.12.4-4.12.1
spice-client-debuginfo-0.12.4-4.12.1
spice-debugsource-0.12.4-4.12.1


References:

https://www.suse.com/security/cve/CVE-2016-0749.html
https://www.suse.com/security/cve/CVE-2016-2150.html
https://bugzilla.suse.com/982385
https://bugzilla.suse.com/982386


< Previous Next >
This Thread
  • No further messages