Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-RU-2016:1678-1: Recommended update for python-dateutil
openSUSE Recommended Update: Recommended update for python-dateutil
______________________________________________________________________________

Announcement ID: openSUSE-RU-2016:1678-1
Rating: low
References: #978730
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:


This update provides python-dateutil 2.4.2, which brings several fixes and
enhancements:

- Updated zoneinfo to 2015b.
- Fixed issue with parsing of tzstr on Python 2.7.x; tzstr will now be
decoded if not a unicode type.
- Fix a parser issue where AM and PM tokens were showing up in fuzzy date
stamps, triggering inappropriate errors.
- Missing function 'setcachsize' removed from zoneinfo __all__ list,
fixing an issue with wildcard imports of dateutil.zoneinfo.
- Added explicit check for valid hours if AM/PM is specified in parser.
- Fix error where parser allowed some invalid dates, overwriting existing
hours with the last 2-digit number in the string.
- Fix and add test for Python 2.x compatibility with boolean checking of
relativedelta objects.
- Replaced parse() calls with explicit datetime objects in unit tests
unrelated to parser.
- Changed private _byxxx from sets to sorted tuples and fixed one
currently unreachable bug in _construct_byset.
- Additional documentation for parser and rrule.
- Formatting fixes to documentation of rrule and README.rst.
- Fix an issue with relativedelta and freezegun.
- Fix minimal version requirement for python-six.
- Many rrule changes and fixes, including defusing some infinite loops.
- Changed many aspects of dealing with the zone info file. Instead of a
cache, all the zones are loaded to memory, but symbolic links are loaded
only once, so not much memory is used.

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-767=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (noarch):

python-dateutil-2.4.2-14.1


References:

https://bugzilla.suse.com/978730


< Previous Next >
This Thread
  • No further messages