Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:1567-1: moderate: Security update for libtasn1
openSUSE Security Update: Security update for libtasn1
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1567-1
Rating: moderate
References: #929414 #961491 #982779
Cross-References: CVE-2015-3622 CVE-2016-4008
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for libtasn1 fixes the following issues:

- Malformed asn1 definitions could have caused a segmentation fault in the
asn1 definition parser (bsc#961491)
- CVE-2015-3622: Fixed invalid read in octet string decoding (bsc#929414)
- CVE-2016-4008: Fixed infinite loop while parsing DER certificates
(bsc#982779)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-716=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libtasn1-3.7-2.7.1
libtasn1-6-3.7-2.7.1
libtasn1-6-debuginfo-3.7-2.7.1
libtasn1-debuginfo-3.7-2.7.1
libtasn1-debugsource-3.7-2.7.1
libtasn1-devel-3.7-2.7.1

- openSUSE 13.2 (x86_64):

libtasn1-6-32bit-3.7-2.7.1
libtasn1-6-debuginfo-32bit-3.7-2.7.1
libtasn1-devel-32bit-3.7-2.7.1


References:

https://www.suse.com/security/cve/CVE-2015-3622.html
https://www.suse.com/security/cve/CVE-2016-4008.html
https://bugzilla.suse.com/929414
https://bugzilla.suse.com/961491
https://bugzilla.suse.com/982779


< Previous Next >
This Thread
  • No further messages