Mailinglist Archive: opensuse-updates (117 mails)

< Previous Next >
openSUSE-SU-2016:1118-1: moderate: Security update for giflib
openSUSE Security Update: Security update for giflib
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1118-1
Rating: moderate
References: #974847
Cross-References: CVE-2016-3977
Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update fixes the following issue:

Heap buffer overflow in gif2rgb (CVE-2016-3977)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch 2016-497=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

giflib-debugsource-5.0.5-2.9.1
giflib-devel-5.0.5-2.9.1
giflib-progs-5.0.5-2.9.1
giflib-progs-debuginfo-5.0.5-2.9.1
libgif6-5.0.5-2.9.1
libgif6-debuginfo-5.0.5-2.9.1

- openSUSE 13.1 (x86_64):

giflib-devel-32bit-5.0.5-2.9.1
libgif6-32bit-5.0.5-2.9.1
libgif6-debuginfo-32bit-5.0.5-2.9.1


References:

https://www.suse.com/security/cve/CVE-2016-3977.html
https://bugzilla.suse.com/974847


< Previous Next >
This Thread
  • No further messages