Mailinglist Archive: opensuse-updates (117 mails)

< Previous Next >
openSUSE-SU-2016:1082-1: moderate: Security update for optipng
openSUSE Security Update: Security update for optipng
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1082-1
Rating: moderate
References: #973992
Cross-References: CVE-2016-2191 CVE-2016-3981 CVE-2016-3982

Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

optipng was updated to fix one security issue.

This security issue was fixed:
- CVE-2016-2191: Invalid write while processing bitmap images (bsc#973992).
- CVE-2016-3981: Heap buffer overflow pngxrbmp.c bmp_read_rows
- CVE-2016-3982: Heap buffer overflow pngxrbmp.c bmp_rle4_fread


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-469=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

optipng-0.7.5-2.3.2
optipng-debuginfo-0.7.5-2.3.2
optipng-debugsource-0.7.5-2.3.2


References:

https://www.suse.com/security/cve/CVE-2016-2191.html
https://www.suse.com/security/cve/CVE-2016-3981.html
https://www.suse.com/security/cve/CVE-2016-3982.html
https://bugzilla.suse.com/973992


< Previous Next >
This Thread
  • No further messages