Mailinglist Archive: opensuse-updates (117 mails)

< Previous Next >
openSUSE-SU-2016:1007-1: moderate: Security update for cairo
openSUSE Security Update: Security update for cairo
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1007-1
Rating: moderate
References: #971964
Cross-References: CVE-2016-3190
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

cairo was updated to fix one security issue.

This security issue was fixed:
- CVE-2016-3190: Out of bounds read in fill_xrgb32_lerp_opaque_spans
(bsc#971964).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-446=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

cairo-debugsource-1.14.0-7.11.1
cairo-devel-1.14.0-7.11.1
cairo-tools-1.14.0-7.11.1
cairo-tools-debuginfo-1.14.0-7.11.1
libcairo-gobject2-1.14.0-7.11.1
libcairo-gobject2-debuginfo-1.14.0-7.11.1
libcairo-script-interpreter2-1.14.0-7.11.1
libcairo-script-interpreter2-debuginfo-1.14.0-7.11.1
libcairo2-1.14.0-7.11.1
libcairo2-debuginfo-1.14.0-7.11.1

- openSUSE 13.2 (x86_64):

cairo-devel-32bit-1.14.0-7.11.1
libcairo-gobject2-32bit-1.14.0-7.11.1
libcairo-gobject2-debuginfo-32bit-1.14.0-7.11.1
libcairo-script-interpreter2-32bit-1.14.0-7.11.1
libcairo-script-interpreter2-debuginfo-32bit-1.14.0-7.11.1
libcairo2-32bit-1.14.0-7.11.1
libcairo2-debuginfo-32bit-1.14.0-7.11.1


References:

https://www.suse.com/security/cve/CVE-2016-3190.html
https://bugzilla.suse.com/971964


< Previous Next >
This Thread
  • No further messages