Mailinglist Archive: opensuse-updates (170 mails)

< Previous Next >
openSUSE-SU-2016:0501-1: moderate: Security update for krb5
openSUSE Security Update: Security update for krb5
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:0501-1
Rating: moderate
References: #963964 #963968 #963975
Cross-References: CVE-2015-8629 CVE-2015-8630 CVE-2015-8631

Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


This update for krb5 fixes the following issues:

- CVE-2015-8629: Information leak authenticated attackers with permissions
to modify the database (bsc#963968)
- CVE-2015-8630: An authenticated attacker with permission to modify a
principal entry may have caused kadmind to crash (bsc#963964)
- CVE-2015-8631: An authenticated attacker could have caused a memory leak
in auditd by supplying a null principal name in request (bsc#963975)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-230=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

krb5-1.12.1-27.1
krb5-client-1.12.1-27.1
krb5-client-debuginfo-1.12.1-27.1
krb5-debuginfo-1.12.1-27.1
krb5-debugsource-1.12.1-27.1
krb5-devel-1.12.1-27.1
krb5-doc-1.12.1-27.1
krb5-mini-1.12.1-27.1
krb5-mini-debuginfo-1.12.1-27.1
krb5-mini-debugsource-1.12.1-27.1
krb5-mini-devel-1.12.1-27.1
krb5-plugin-kdb-ldap-1.12.1-27.1
krb5-plugin-kdb-ldap-debuginfo-1.12.1-27.1
krb5-plugin-preauth-otp-1.12.1-27.1
krb5-plugin-preauth-otp-debuginfo-1.12.1-27.1
krb5-plugin-preauth-pkinit-1.12.1-27.1
krb5-plugin-preauth-pkinit-debuginfo-1.12.1-27.1
krb5-server-1.12.1-27.1
krb5-server-debuginfo-1.12.1-27.1

- openSUSE Leap 42.1 (x86_64):

krb5-32bit-1.12.1-27.1
krb5-debuginfo-32bit-1.12.1-27.1
krb5-devel-32bit-1.12.1-27.1


References:

https://www.suse.com/security/cve/CVE-2015-8629.html
https://www.suse.com/security/cve/CVE-2015-8630.html
https://www.suse.com/security/cve/CVE-2015-8631.html
https://bugzilla.suse.com/963964
https://bugzilla.suse.com/963968
https://bugzilla.suse.com/963975


< Previous Next >
This Thread
  • No further messages