Mailinglist Archive: opensuse-updates (170 mails)

< Previous Next >
openSUSE-SU-2016:0478-1: moderate: Security update for socat
openSUSE Security Update: Security update for socat
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:0478-1
Rating: moderate
References: #938913 #964844
Cross-References: CVE-2015-4000
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


This update for socat fixes the following issues:

Changes in socat:
- update to 1.7.3.1, security fixes:
* Socat security advisory 7 and MSVR-1499: "Bad DH p parameter in
OpenSSL" (boo#938913 and CVE-2015-4000).
* Socat security advisory 8: "Stack overflow in arguments parser"
(boo#964844)

- Update to version 1.7.3.0
* Too many changes to list; please read the CHANGES file for news


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-215=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-215=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

socat-1.7.3.1-6.1
socat-debuginfo-1.7.3.1-6.1
socat-debugsource-1.7.3.1-6.1

- openSUSE 13.2 (i586 x86_64):

socat-1.7.3.1-2.3.1
socat-debuginfo-1.7.3.1-2.3.1
socat-debugsource-1.7.3.1-2.3.1


References:

https://www.suse.com/security/cve/CVE-2015-4000.html
https://bugzilla.suse.com/938913
https://bugzilla.suse.com/964844


< Previous Next >
This Thread
  • No further messages