Mailinglist Archive: opensuse-updates (170 mails)

< Previous Next >
openSUSE-SU-2016:0373-1: moderate: Security update for curl
openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:0373-1
Rating: moderate
References: #962983 #962996
Cross-References: CVE-2016-0755
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


This update for curl fixes the following issues:

- CVE-2016-0755: libcurl would reuse NTLM-authenticated proxy connections
without properly making sure that the connection was authenticated with
the same credentials as set for this transfer (bsc#962983)

The following tracked bugs only affect the test suite:

- bsc#962996: Expired cookie in test 46 caused test failures


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-153=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

curl-7.42.1-19.1
curl-debuginfo-7.42.1-19.1
curl-debugsource-7.42.1-19.1
libcurl-devel-7.42.1-19.1
libcurl4-7.42.1-19.1
libcurl4-debuginfo-7.42.1-19.1

- openSUSE 13.2 (x86_64):

libcurl-devel-32bit-7.42.1-19.1
libcurl4-32bit-7.42.1-19.1
libcurl4-debuginfo-32bit-7.42.1-19.1


References:

https://www.suse.com/security/cve/CVE-2016-0755.html
https://bugzilla.suse.com/962983
https://bugzilla.suse.com/962996


< Previous Next >
This Thread
  • No further messages