Mailinglist Archive: opensuse-updates (170 mails)

< Previous Next >
openSUSE-SU-2016:0372-1: moderate: Security update for rubygem-actionpack-4_2, rubygem-actionview-4_2, rubygem-activemodel-4_2, rubygem-activerecord-4_2, rubygem-activesupport-4_2
openSUSE Security Update: Security update for rubygem-actionpack-4_2,
rubygem-actionview-4_2, rubygem-activemodel-4_2, rubygem-activerecord-4_2,
rubygem-activesupport-4_2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:0372-1
Rating: moderate
References: #963329 #963330 #963331 #963332 #963334 #963335

Cross-References: CVE-2015-7576 CVE-2015-7577 CVE-2015-7581
CVE-2016-0751 CVE-2016-0752 CVE-2016-0753

Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:


This update for rubygem-actionpack-4_2, rubygem-actionview-4_2,
rubygem-activemodel-4_2, rubygem-activerecord-4_2,
rubygem-activesupport-4_2 fixes the following issues:

- CVE-2015-7576: Timing attack vulnerability in basic authentication in
Action Controller (boo#963329)
- CVE-2016-0752: directory traversal and information leak in Action View
(boo#963332)
- CVE-2015-7581: unbounded memory growth DoS via wildcard controller
routes (boo#963335)
- CVE-2016-0751: rubygem-actionpack: Object Leak DoS (boo#963331)
- CVE-2016-0753: Input Validation Circumvention (boo#963334)
- CVE-2015-7577: Nested attributes rejection proc bypass (boo#963330)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-159=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

ruby2.1-rubygem-actionpack-4_2-4.2.4-6.1
ruby2.1-rubygem-actionpack-doc-4_2-4.2.4-6.1
ruby2.1-rubygem-actionview-4_2-4.2.4-6.1
ruby2.1-rubygem-actionview-doc-4_2-4.2.4-6.1
ruby2.1-rubygem-activemodel-4_2-4.2.4-6.1
ruby2.1-rubygem-activemodel-doc-4_2-4.2.4-6.1
ruby2.1-rubygem-activerecord-4_2-4.2.4-6.1
ruby2.1-rubygem-activerecord-doc-4_2-4.2.4-6.1
ruby2.1-rubygem-activesupport-4_2-4.2.4-6.1
ruby2.1-rubygem-activesupport-doc-4_2-4.2.4-6.1


References:

https://www.suse.com/security/cve/CVE-2015-7576.html
https://www.suse.com/security/cve/CVE-2015-7577.html
https://www.suse.com/security/cve/CVE-2015-7581.html
https://www.suse.com/security/cve/CVE-2016-0751.html
https://www.suse.com/security/cve/CVE-2016-0752.html
https://www.suse.com/security/cve/CVE-2016-0753.html
https://bugzilla.suse.com/963329
https://bugzilla.suse.com/963330
https://bugzilla.suse.com/963331
https://bugzilla.suse.com/963332
https://bugzilla.suse.com/963334
https://bugzilla.suse.com/963335


< Previous Next >
This Thread
  • No further messages