Mailinglist Archive: opensuse-updates (170 mails)

< Previous Next >
openSUSE-RU-2016:0369-1: Recommended update for suse-xsl-stylesheets
openSUSE Recommended Update: Recommended update for suse-xsl-stylesheets
______________________________________________________________________________

Announcement ID: openSUSE-RU-2016:0369-1
Rating: low
References: #955663 #962402
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has two recommended fixes can now be
installed.

Description:


suse-xsl-stylesheets was updated to version 2.0.4, which brings several
fixes and enhancements:

Schema:

- Allow constant and see (inside <indexterm>); make db.all.blocks zero or
more (*) for question
- Remove XLinks from DB5 elements
- Disallow db.all.blocks in lists
- Remove <menuchoice> from guiinlines (Novdoc)
- Allow <menuchoice> in titles (Novdoc)

Stylesheets (PDF):

- "Unbolded" admonition titles
- Odd space in footer where <productname> used to be, <productname> not
displayed on book title page
- Fix style of <sect5> titles (bsc#955663)
- FOP doesn't like empty <fo:table-cell>s
- Make <remark> handling a little more elegant
- Attribute sets: fix logic for replacing bold/italic in CJK languages

Stylesheets (XHTML):

- Make Callouts "uncopyable"
- Don't link inline images
- Publication date is incorrectly capitalized
- Create better plain-text output via DAPS
- debug.filename-id: Use xml:id for metadata
- Various fixes for JS code for tracker
- Style for <package>

Common Stylesheet Changes:

- xrefs to variablelists in another book are broken
- Trim spaces/newlines at beginning/end of verbatim elements
- Fix bugtracker for db4.

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-158=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (noarch):

suse-xsl-stylesheets-2.0.4-12.2


References:

https://bugzilla.suse.com/955663
https://bugzilla.suse.com/962402


< Previous Next >
This Thread
  • No further messages