Mailinglist Archive: opensuse-updates (120 mails)

< Previous Next >
openSUSE-SU-2016:0218-1: moderate: Security update for cgit
openSUSE Security Update: Security update for cgit
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:0218-1
Rating: moderate
References: #948969 #961916
Cross-References: CVE-2016-1899 CVE-2016-1900 CVE-2016-1901

Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


This update to cgit 0.12 fixes the following issues:

- CVE-2016-1899: Reflected Cross Site Scripting and Header Injection in
Mimetype Query String
- CVE-2016-1900: Stored Cross Site Scripting and Header Injection in
Filename Parameter
- CVE-2016-1901: Integer Overflow resulting in Buffer Overflow

The bundled git version was updated to 2.7.0.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch 2016-86=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

cgit-0.12-11.6.1
cgit-debuginfo-0.12-11.6.1
cgit-debugsource-0.12-11.6.1


References:

https://www.suse.com/security/cve/CVE-2016-1899.html
https://www.suse.com/security/cve/CVE-2016-1900.html
https://www.suse.com/security/cve/CVE-2016-1901.html
https://bugzilla.suse.com/948969
https://bugzilla.suse.com/961916


< Previous Next >
This Thread
  • No further messages