Mailinglist Archive: opensuse-updates (144 mails)

< Previous Next >
openSUSE-SU-2015:2372-1: moderate: Security update for libxml2
openSUSE Security Update: Security update for libxml2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:2372-1
Rating: moderate
References: #928193 #951734 #951735 #954429 #956018 #956021
#956260 #957105 #957106 #957107 #957109 #957110

Cross-References: CVE-2014-0191 CVE-2014-3660 CVE-2015-1819
CVE-2015-5312 CVE-2015-7497 CVE-2015-7498
CVE-2015-7499 CVE-2015-7500 CVE-2015-7941
CVE-2015-7942 CVE-2015-8035 CVE-2015-8241
CVE-2015-8242 CVE-2015-8317
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes 14 vulnerabilities is now available.

Description:

- update to 2.9.3
* full changelog: http://www.xmlsoft.org/news.html
* fixed CVEs: CVE-2015-8242, CVE-2015-7500, CVE-2015-7499,
CVE-2015-5312, CVE-2015-7497, CVE-2015-7498, CVE-2015-8035,
CVE-2015-7942, CVE-2015-1819, CVE-2015-7941, CVE-2014-3660,
CVE-2014-0191, CVE-2015-8241, CVE-2015-8317
* fixed bugs: [bsc#928193], [bsc#951734], [bsc#951735], [bsc#954429],
[bsc#956018], [bsc#956021], [bsc#956260], [bsc#957105], [bsc#957106],
[bsc#957107], [bsc#957109], [bsc#957110]


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-959=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-959=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libxml2-2-2.9.3-7.4.1
libxml2-2-debuginfo-2.9.3-7.4.1
libxml2-debugsource-2.9.3-7.4.1
libxml2-devel-2.9.3-7.4.1
libxml2-tools-2.9.3-7.4.1
libxml2-tools-debuginfo-2.9.3-7.4.1
python-libxml2-2.9.3-7.4.1
python-libxml2-debuginfo-2.9.3-7.4.1
python-libxml2-debugsource-2.9.3-7.4.1

- openSUSE 13.2 (x86_64):

libxml2-2-32bit-2.9.3-7.4.1
libxml2-2-debuginfo-32bit-2.9.3-7.4.1
libxml2-devel-32bit-2.9.3-7.4.1

- openSUSE 13.2 (noarch):

libxml2-doc-2.9.3-7.4.1

- openSUSE 13.1 (i586 x86_64):

libxml2-2-2.9.3-2.19.1
libxml2-2-debuginfo-2.9.3-2.19.1
libxml2-debugsource-2.9.3-2.19.1
libxml2-devel-2.9.3-2.19.1
libxml2-tools-2.9.3-2.19.1
libxml2-tools-debuginfo-2.9.3-2.19.1
python-libxml2-2.9.3-2.19.1
python-libxml2-debuginfo-2.9.3-2.19.1
python-libxml2-debugsource-2.9.3-2.19.1

- openSUSE 13.1 (x86_64):

libxml2-2-32bit-2.9.3-2.19.1
libxml2-2-debuginfo-32bit-2.9.3-2.19.1
libxml2-devel-32bit-2.9.3-2.19.1

- openSUSE 13.1 (noarch):

libxml2-doc-2.9.3-2.19.1


References:

https://www.suse.com/security/cve/CVE-2014-0191.html
https://www.suse.com/security/cve/CVE-2014-3660.html
https://www.suse.com/security/cve/CVE-2015-1819.html
https://www.suse.com/security/cve/CVE-2015-5312.html
https://www.suse.com/security/cve/CVE-2015-7497.html
https://www.suse.com/security/cve/CVE-2015-7498.html
https://www.suse.com/security/cve/CVE-2015-7499.html
https://www.suse.com/security/cve/CVE-2015-7500.html
https://www.suse.com/security/cve/CVE-2015-7941.html
https://www.suse.com/security/cve/CVE-2015-7942.html
https://www.suse.com/security/cve/CVE-2015-8035.html
https://www.suse.com/security/cve/CVE-2015-8241.html
https://www.suse.com/security/cve/CVE-2015-8242.html
https://www.suse.com/security/cve/CVE-2015-8317.html
https://bugzilla.suse.com/928193
https://bugzilla.suse.com/951734
https://bugzilla.suse.com/951735
https://bugzilla.suse.com/954429
https://bugzilla.suse.com/956018
https://bugzilla.suse.com/956021
https://bugzilla.suse.com/956260
https://bugzilla.suse.com/957105
https://bugzilla.suse.com/957106
https://bugzilla.suse.com/957107
https://bugzilla.suse.com/957109
https://bugzilla.suse.com/957110


< Previous Next >
This Thread
  • No further messages