Mailinglist Archive: opensuse-updates (144 mails)

< Previous Next >
openSUSE-RU-2015:2311-1: moderate: Recommended update for clamav
openSUSE Recommended Update: Recommended update for clamav
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:2311-1
Rating: moderate
References: #957728
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:


ClamAV was updated to version 0.99, bringing the following fixes and
enhancements:

- Support in ClamAV logical signatures for many of the features added for
YARA, such as Perl Compatible Regular Expressions, alternate strings,
and YARA string attributes. See signatures.pdf for full details.
- New and improved on-access scanning for Linux. See clamdoc.pdf for
details on the new on-access capabilities.
- A new ClamAV API callback function that is invoked when a virus is
found. This is intended primarily for applications running in all-match
mode. Any applications using all-match mode must use the new callback
function to record and report detected viruses.
- Configurable default password list to attempt zip file decryption.
- TIFF file support.
- A new signature target type for designating signatures to run against
files with unknown file types.
- Improved fidelity of the "data loss prevention" heuristic algorithm.
- Support for LZMA decompression within Adobe Flash files.
- Support for MSO attachments within Microsoft Office 2003 XML files.
- A new sigtool option(--ascii-normalize) allowing signature authors to
more easily generate normalized versions of ascii files. This update was
imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-930=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

clamav-0.99-4.1
clamav-debuginfo-0.99-4.1
clamav-debugsource-0.99-4.1


References:

https://bugzilla.suse.com/957728


< Previous Next >
This Thread
  • No further messages