Mailinglist Archive: opensuse-updates (144 mails)

< Previous Next >
openSUSE-RU-2015:2260-1: Recommended update for xpp3
openSUSE Recommended Update: Recommended update for xpp3
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:2260-1
Rating: low
References: #954455
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:


xpp3 has been updated to version 1.1.4c, bringing the following fixes:

- Updated SAX2 driver add-on. This includes a backward incompatible
change: XmlElement will no longer accept null children (null can not be
passed to addChild/addElement).
- Fixed NullPointerException in MXParserCachingStrings.
- Calling defineEntityReplacementText now works before calling setInput.
- Fixed Serializer to no longer write endTag unmatching startTag.
- Fixed XmlPull SAX2 driver not sending correct qname (rawName) in
startElement() callback.
- Fixed DOM2XmlPullBuilder not handling default namespaces. This update
was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-899=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (noarch):

xpp3-1.1.4c-27.1
xpp3-javadoc-1.1.4c-27.1
xpp3-minimal-1.1.4c-27.1


References:

https://bugzilla.suse.com/954455


< Previous Next >
This Thread
  • No further messages