Mailinglist Archive: opensuse-updates (144 mails)

< Previous Next >
openSUSE-RU-2015:2225-1: moderate: Recommended update for kiwi
openSUSE Recommended Update: Recommended update for kiwi
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:2225-1
Rating: moderate
References: #944017 #946387 #949046 #950735 #950999
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has 5 recommended fixes can now be installed.

Description:


This update for kiwi fixes the following issues:

- Updated version from 7.03.24 to v7.03.37
- Update suse-leap-42.1-JeOS: Use ext4 as write filesystem in overlayfs,
btrfs is broken for this use case (boo#950999)
- Allow ext4 to be set in hybridpersistent_filesystem
- Fix appdata generation on product builds with multiple media
- Retrieve vm tools version from vmtoolsd
- Deleted __checkMountDependencies runtime check
- Added Leap 42.1 support for kiwi --describe: Allow to analyse Leap
Systems
- Bundle all built OEM images
- Updated translations
- Added vmdk descriptor update
- Make check for running udev daemon more stable
- Fixed __checkRootDirOutsideImageDescription
- Fixed kernelcmdline setup for EFI live ISO images
- Cleanup validation of multipath and ataraid scan
- Set noudevsync only if udevd is not running. (boo#950735)
- Actively relocate GPT backup data at end of disk
- Add ramdisk device filter for leap JeOS
- Added __checkRootDirOutsideImageDescription
- Apply missing syntax fix
- Add SLE-12-SP1 plugin
- Support generic multipath lookup (boo#946387)
- Support multipath lookup for ZFCP devices on s390 (boo#944017)
- Provide a startMultipathd method
- Update -requires matcher for SLE12 SP1 (boo#949046)
- Rename SLE JeOS descriptions (fate#319430)
- Fixed resetBootBind copy of boot data
- Update suse-13.2-JeOS: There is no need to have kernel-debug in the
delete section actually the package is not installed
- Fixed RHEL 6 and CentOS 6 and derivatives using boot='vmxboot/rhel-06.0'
or similiar should be handled like SLE 11 not using a tmpfs on /run
- Drop imagePrepDevice
- Set PReP device


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-871=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

kiwi-7.03.38-5.4
kiwi-debugsource-7.03.38-5.4
kiwi-desc-isoboot-7.03.38-5.4
kiwi-desc-isoboot-requires-7.03.38-5.4
kiwi-desc-netboot-7.03.38-5.4
kiwi-desc-netboot-requires-7.03.38-5.4
kiwi-desc-oemboot-7.03.38-5.4
kiwi-desc-oemboot-requires-7.03.38-5.4
kiwi-desc-vmxboot-7.03.38-5.4
kiwi-desc-vmxboot-requires-7.03.38-5.4
kiwi-instsource-7.03.38-5.4
kiwi-templates-7.03.38-5.4
kiwi-tools-7.03.38-5.4
kiwi-tools-debuginfo-7.03.38-5.4

- openSUSE Leap 42.1 (noarch):

kiwi-doc-7.03.38-5.4
kiwi-media-requires-7.03.38-5.4
kiwi-pxeboot-7.03.38-5.4
kiwi-requires-7.03.38-5.4
kiwi-test-7.03.38-5.4


References:

https://bugzilla.suse.com/944017
https://bugzilla.suse.com/946387
https://bugzilla.suse.com/949046
https://bugzilla.suse.com/950735
https://bugzilla.suse.com/950999


< Previous Next >
This Thread
  • No further messages