Mailinglist Archive: opensuse-updates (144 mails)

< Previous Next >
openSUSE-RU-2015:2197-1: moderate: Recommended update for docker
openSUSE Recommended Update: Recommended update for docker
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:2197-1
Rating: moderate
References: #956434
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:


This update for docker provides version 1.9.1 with various fixes and
improvements (boo#956434):

- Runtime:
+ Do not prevent daemon from booting if images could not be restored
+ Force ipc mount to unmount on daemon shutdown/init
+ Turn ipc unmount errors into warnings
+ Fix `docker stats` performance regression
+ Clarify cryptic error message upon `docker logs` if `--log-driver=none
+ Fix seldom panics
+ Fix opq whiteouts problems for files with dot prefix
+ devicemapper: Try defaulting to xfs instead of ext4 for performance
reasons
+ devicemapper: Fix displayed fs in docker info
+ Selinux: only relabel if user requested so with the `z` option
+ Do not make network calls when normalizing names

- Client:
+ Fix `docker login` on windows
+ Fix bug with `docker inspect` output when not connected to daemon
+ Fix `docker inspect -f {{.hostconfig.dns}} somecontainer

- Builder:
+ Fix regression with symlink behavior in add/copy

- Networking:
+ Allow passing a network id as an argument for `--net
+ Fix connect to host and prevent disconnect from host for `host` network
+ Fix `--fixed-cidr` issue when gateway ip falls in ip-range and
ip-range is not the first block in the network
+ Restore deterministic `ipv6` generation from `mac` address on default
`bridge` network
+ Allow port-mapping only for endpoints created on docker run
+ Fixed an endpoint delete issue with a possible stale sbox

- Distribution:
+ Correct parent chain in v2 push when v1compatibility files on the disk
are inconsistent


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-854=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (x86_64):

docker-1.9.1-7.1
docker-debuginfo-1.9.1-7.1
docker-debugsource-1.9.1-7.1

- openSUSE Leap 42.1 (noarch):

docker-bash-completion-1.9.1-7.1
docker-test-1.9.1-7.1
docker-zsh-completion-1.9.1-7.1


References:

https://bugzilla.suse.com/956434


< Previous Next >
This Thread
  • No further messages