Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-SU-2015:2153-1: Security update for GnuPG
openSUSE Security Update: Security update for GnuPG
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:2153-1
Rating: low
References: #918089 #918090
Cross-References: CVE-2015-1606 CVE-2015-1607
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

GnuPG was updated to fix two memory handling issues with potential
security impact:

* CVE-2015-1606: Invalid memory read using a garbled keyring (bsc#918089)
* CVE-2015-1607: memcpy with overlapping ranges (bsc#918090)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-840=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-840=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

gpg2-2.0.26-2.3.1
gpg2-debuginfo-2.0.26-2.3.1
gpg2-debugsource-2.0.26-2.3.1

- openSUSE 13.2 (noarch):

gpg2-lang-2.0.26-2.3.1

- openSUSE 13.1 (i586 x86_64):

gpg2-2.0.22-12.1
gpg2-debuginfo-2.0.22-12.1
gpg2-debugsource-2.0.22-12.1

- openSUSE 13.1 (noarch):

gpg2-lang-2.0.22-12.1


References:

https://www.suse.com/security/cve/CVE-2015-1606.html
https://www.suse.com/security/cve/CVE-2015-1607.html
https://bugzilla.suse.com/918089
https://bugzilla.suse.com/918090


< Previous Next >
This Thread
  • No further messages