Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-SU-2015:2103-1: moderate: Security update for strongswan
openSUSE Security Update: Security update for strongswan
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:2103-1
Rating: moderate
References: #953817
Cross-References: CVE-2015-8023
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

The strongswan package was updated to fix the following security issue:

- CVE-2015-8023: Fixed an authentication bypass vulnerability in the
eap-mschapv2 plugin (bsc#953817).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-810=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-810=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-810=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

strongswan-5.2.2-7.1
strongswan-debugsource-5.2.2-7.1
strongswan-hmac-5.2.2-7.1
strongswan-ipsec-5.2.2-7.1
strongswan-ipsec-debuginfo-5.2.2-7.1
strongswan-libs0-5.2.2-7.1
strongswan-libs0-debuginfo-5.2.2-7.1
strongswan-mysql-5.2.2-7.1
strongswan-mysql-debuginfo-5.2.2-7.1
strongswan-nm-5.2.2-7.1
strongswan-nm-debuginfo-5.2.2-7.1
strongswan-sqlite-5.2.2-7.1
strongswan-sqlite-debuginfo-5.2.2-7.1

- openSUSE Leap 42.1 (noarch):

strongswan-doc-5.2.2-7.1

- openSUSE 13.2 (i586 x86_64):

strongswan-5.1.3-4.14.1
strongswan-debugsource-5.1.3-4.14.1
strongswan-ipsec-5.1.3-4.14.1
strongswan-ipsec-debuginfo-5.1.3-4.14.1
strongswan-libs0-5.1.3-4.14.1
strongswan-libs0-debuginfo-5.1.3-4.14.1
strongswan-mysql-5.1.3-4.14.1
strongswan-mysql-debuginfo-5.1.3-4.14.1
strongswan-nm-5.1.3-4.14.1
strongswan-nm-debuginfo-5.1.3-4.14.1
strongswan-sqlite-5.1.3-4.14.1
strongswan-sqlite-debuginfo-5.1.3-4.14.1

- openSUSE 13.2 (noarch):

strongswan-doc-5.1.3-4.14.1

- openSUSE 13.1 (i586 x86_64):

strongswan-5.1.1-14.1
strongswan-debugsource-5.1.1-14.1
strongswan-ipsec-5.1.1-14.1
strongswan-ipsec-debuginfo-5.1.1-14.1
strongswan-libs0-5.1.1-14.1
strongswan-libs0-debuginfo-5.1.1-14.1
strongswan-mysql-5.1.1-14.1
strongswan-mysql-debuginfo-5.1.1-14.1
strongswan-nm-5.1.1-14.1
strongswan-nm-debuginfo-5.1.1-14.1
strongswan-sqlite-5.1.1-14.1
strongswan-sqlite-debuginfo-5.1.1-14.1

- openSUSE 13.1 (noarch):

strongswan-doc-5.1.1-14.1


References:

https://www.suse.com/security/cve/CVE-2015-8023.html
https://bugzilla.suse.com/953817


< Previous Next >
This Thread
  • No further messages