Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-SU-2015:1965-1: moderate: Security update for xen
openSUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1965-1
Rating: moderate
References: #877642 #932267 #950367 #950703 #950705 #950706
#951845
Cross-References: CVE-2014-0222 CVE-2015-4037 CVE-2015-7835
CVE-2015-7969 CVE-2015-7971 CVE-2015-7972

Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that solves 6 vulnerabilities and has one errata
is now available.

Description:


Xen was updated to fix 6 security issues.

These security issues were fixed:
- CVE-2014-0222: Validate L2 table size to avoid integer overflows
(bsc#877642).
- CVE-2015-4037: Insecure temporary file use in /net/slirp.c (bsc#932267).
- CVE-2015-7835: Uncontrolled creation of large page mappings by PV guests
(bsc#950367).
- CVE-2015-7969: Leak of per-domain profiling-related vcpu pointer array
(DoS) (bsc#950705 bsc#950703).
- CVE-2015-7971: Some pmu and profiling hypercalls log without rate
limiting (bsc#950706).
- CVE-2015-7972: Populate-on-demand balloon size inaccuracy can crash
guests (bsc#951845).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-730=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

xen-debugsource-4.5.1_12-3.1
xen-devel-4.5.1_12-3.1
xen-libs-4.5.1_12-3.1
xen-libs-debuginfo-4.5.1_12-3.1
xen-tools-domU-4.5.1_12-3.1
xen-tools-domU-debuginfo-4.5.1_12-3.1

- openSUSE Leap 42.1 (x86_64):

xen-4.5.1_12-3.1
xen-doc-html-4.5.1_12-3.1
xen-kmp-default-4.5.1_12_k4.1.12_1-3.1
xen-kmp-default-debuginfo-4.5.1_12_k4.1.12_1-3.1
xen-libs-32bit-4.5.1_12-3.1
xen-libs-debuginfo-32bit-4.5.1_12-3.1
xen-tools-4.5.1_12-3.1
xen-tools-debuginfo-4.5.1_12-3.1


References:

https://www.suse.com/security/cve/CVE-2014-0222.html
https://www.suse.com/security/cve/CVE-2015-4037.html
https://www.suse.com/security/cve/CVE-2015-7835.html
https://www.suse.com/security/cve/CVE-2015-7969.html
https://www.suse.com/security/cve/CVE-2015-7971.html
https://www.suse.com/security/cve/CVE-2015-7972.html
https://bugzilla.suse.com/877642
https://bugzilla.suse.com/932267
https://bugzilla.suse.com/950367
https://bugzilla.suse.com/950703
https://bugzilla.suse.com/950705
https://bugzilla.suse.com/950706
https://bugzilla.suse.com/951845


< Previous Next >
This Thread
  • No further messages