Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-SU-2015:1927-1: moderate: Security update for polkit
openSUSE Security Update: Security update for polkit
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1927-1
Rating: moderate
References: #912889 #933922 #935119 #939246 #943816 #950114

Cross-References: CVE-2015-3218 CVE-2015-3255 CVE-2015-3256
CVE-2015-4625
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that solves four vulnerabilities and has two
fixes is now available.

Description:


polkit was updated to the 0.113 release, fixing security issues and bugs.

Security issues fixed:
* Fixes CVE-2015-4625, a local privilege escalation due to predictable
authentication session cookie values. Thanks to Tavis Ormandy, Google
Project Zero for reporting this issue. For the future, authentication
agents are encouraged to use PolkitAgentSession instead of using the
D-Bus agent response API directly. (bsc#935119)
* Fixes CVE-2015-3256, various memory corruption vulnerabilities in use of
the JavaScript interpreter, possibly leading to local privilege
escalation. (bsc#943816)
* Fixes CVE-2015-3255, a memory corruption vulnerability in handling
duplicate action IDs, possibly leading to local privilege escalation.
Thanks to Laurent Bigonville for reporting this issue. (bsc#939246)
* Fixes CVE-2015-3218, which allowed any local user to crash polkitd.
Thanks to Tavis Ormandy, Google Project Zero, for reporting this issue.
(bsc#933922)

Other issues fixed:
* On systemd-213 and later, the "active" state is shared across all
sessions of an user, instead of being tracked separately.
* pkexec, when not given a program to execute, runs the users shell by
default.
* Fixed shutdown problems on powerpc64le (bsc#950114)
* polkit had a memory leak (bsc#912889)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-711=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

libpolkit0-0.113-6.1
libpolkit0-debuginfo-0.113-6.1
polkit-0.113-6.1
polkit-debuginfo-0.113-6.1
polkit-debugsource-0.113-6.1
polkit-devel-0.113-6.1
polkit-devel-debuginfo-0.113-6.1
typelib-1_0-Polkit-1_0-0.113-6.1

- openSUSE Leap 42.1 (x86_64):

libpolkit0-32bit-0.113-6.1
libpolkit0-debuginfo-32bit-0.113-6.1

- openSUSE Leap 42.1 (noarch):

polkit-doc-0.113-6.1


References:

https://www.suse.com/security/cve/CVE-2015-3218.html
https://www.suse.com/security/cve/CVE-2015-3255.html
https://www.suse.com/security/cve/CVE-2015-3256.html
https://www.suse.com/security/cve/CVE-2015-4625.html
https://bugzilla.suse.com/912889
https://bugzilla.suse.com/933922
https://bugzilla.suse.com/935119
https://bugzilla.suse.com/939246
https://bugzilla.suse.com/943816
https://bugzilla.suse.com/950114


< Previous Next >
This Thread
  • No further messages