Mailinglist Archive: opensuse-updates (61 mails)

< Previous Next >
openSUSE-SU-2015:1773-1: moderate: Security update for docker
openSUSE Security Update: Security update for docker
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1773-1
Rating: moderate
References: #949660
Cross-References: CVE-2014-8178 CVE-2014-8179
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

Docker was updated to 1.8.3 to fix two security issues.

The following vulnerabilities were fixed:

* CVE-2014-8178: layer IDs lead to local graph poisoning (boo#949660)
* CVE-2014-8179: manifest validation and parsing logic errors allow
pull-by-digest validation bypass

In addition, the following change is included:

* --disable-legacy-registry to prevent a daemon from using a v1 registry


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-666=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (x86_64):

docker-1.8.3-43.1
docker-debuginfo-1.8.3-43.1
docker-debugsource-1.8.3-43.1

- openSUSE 13.2 (noarch):

docker-bash-completion-1.8.3-43.1
docker-test-1.8.3-43.1
docker-zsh-completion-1.8.3-43.1


References:

https://www.suse.com/security/cve/CVE-2014-8178.html
https://www.suse.com/security/cve/CVE-2014-8179.html
https://bugzilla.suse.com/949660


< Previous Next >
This Thread
  • No further messages