Mailinglist Archive: opensuse-updates (48 mails)

< Previous Next >
openSUSE-SU-2015:1537-1: moderate: Security update for libvdpau
openSUSE Security Update: Security update for libvdpau
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1537-1
Rating: moderate
References: #943967 #943968 #943969
Cross-References: CVE-2015-5198 CVE-2015-5199 CVE-2015-5200

Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


libvdpau was updated to use secure_getenv() instead of getenv() for
several variables so it can be more safely used in setuid applications.

* CVE-2015-5198: libvdpau: incorrect check for security transition
(bnc#943967)
* CVE-2015-5199: libvdpau: directory traversal in dlopen (bnc#943968)
* CVE-2015-5200: libvdpau: vulnerability in trace functionality
(bnc#943969)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-576=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-576=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libvdpau-debugsource-0.8-2.3.1
libvdpau-devel-0.8-2.3.1
libvdpau1-0.8-2.3.1
libvdpau1-debuginfo-0.8-2.3.1
libvdpau_trace1-0.8-2.3.1
libvdpau_trace1-debuginfo-0.8-2.3.1

- openSUSE 13.2 (x86_64):

libvdpau-devel-32bit-0.8-2.3.1
libvdpau1-32bit-0.8-2.3.1
libvdpau1-debuginfo-32bit-0.8-2.3.1
libvdpau_trace1-32bit-0.8-2.3.1
libvdpau_trace1-debuginfo-32bit-0.8-2.3.1

- openSUSE 13.1 (i586 x86_64):

libvdpau-debugsource-0.6-3.3.1
libvdpau-devel-0.6-3.3.1
libvdpau1-0.6-3.3.1
libvdpau1-debuginfo-0.6-3.3.1
libvdpau_trace1-0.6-3.3.1
libvdpau_trace1-debuginfo-0.6-3.3.1

- openSUSE 13.1 (x86_64):

libvdpau-devel-32bit-0.6-3.3.1
libvdpau1-32bit-0.6-3.3.1
libvdpau1-debuginfo-32bit-0.6-3.3.1
libvdpau_trace1-32bit-0.6-3.3.1
libvdpau_trace1-debuginfo-32bit-0.6-3.3.1


References:

https://www.suse.com/security/cve/CVE-2015-5198.html
https://www.suse.com/security/cve/CVE-2015-5199.html
https://www.suse.com/security/cve/CVE-2015-5200.html
https://bugzilla.suse.com/943967
https://bugzilla.suse.com/943968
https://bugzilla.suse.com/943969


< Previous Next >
This Thread
  • No further messages