Mailinglist Archive: opensuse-updates (71 mails)

< Previous Next >
openSUSE-SU-2015:1325-1: moderate: Security update for openldap2
openSUSE Security Update: Security update for openldap2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1325-1
Rating: moderate
References: #905959 #916897 #916914
Cross-References: CVE-2015-1545 CVE-2015-1546
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

OpenLDAP was updated to fix two security issues and one bug.

The following vulnerabilities were fixed:

* CVE-2015-1546: slapd crash in valueReturnFilter cleanup (bnc#916914)
* CVE-2015-1545: slapd crashes on search with deref control and empty attr
list (bnc#916897)

The following non-security bug was fixed:

* boo#905959: Prevent connection-0 (internal connection) from show up in
the monitor backend


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-526=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-526=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

compat-libldap-2_3-0-2.3.37-8.5.1
compat-libldap-2_3-0-debuginfo-2.3.37-8.5.1
libldap-2_4-2-2.4.39-8.5.1
libldap-2_4-2-debuginfo-2.4.39-8.5.1
openldap2-2.4.39-8.5.1
openldap2-back-meta-2.4.39-8.5.1
openldap2-back-meta-debuginfo-2.4.39-8.5.1
openldap2-back-perl-2.4.39-8.5.1
openldap2-back-perl-debuginfo-2.4.39-8.5.1
openldap2-back-sql-2.4.39-8.5.1
openldap2-back-sql-debuginfo-2.4.39-8.5.1
openldap2-client-2.4.39-8.5.1
openldap2-client-debuginfo-2.4.39-8.5.1
openldap2-client-debugsource-2.4.39-8.5.1
openldap2-debuginfo-2.4.39-8.5.1
openldap2-debugsource-2.4.39-8.5.1
openldap2-devel-2.4.39-8.5.1
openldap2-devel-static-2.4.39-8.5.1

- openSUSE 13.2 (x86_64):

libldap-2_4-2-32bit-2.4.39-8.5.1
libldap-2_4-2-debuginfo-32bit-2.4.39-8.5.1
openldap2-devel-32bit-2.4.39-8.5.1

- openSUSE 13.2 (noarch):

openldap2-doc-2.4.39-8.5.1

- openSUSE 13.1 (i586 x86_64):

libldap-2_4-2-2.4.33-8.3.1
libldap-2_4-2-debuginfo-2.4.33-8.3.1
openldap2-2.4.33-8.3.1
openldap2-back-meta-2.4.33-8.3.1
openldap2-back-meta-debuginfo-2.4.33-8.3.1
openldap2-back-perl-2.4.33-8.3.1
openldap2-back-perl-debuginfo-2.4.33-8.3.1
openldap2-back-sql-2.4.33-8.3.1
openldap2-back-sql-debuginfo-2.4.33-8.3.1
openldap2-client-2.4.33-8.3.1
openldap2-client-debuginfo-2.4.33-8.3.1
openldap2-client-debugsource-2.4.33-8.3.1
openldap2-debuginfo-2.4.33-8.3.1
openldap2-debugsource-2.4.33-8.3.1
openldap2-devel-2.4.33-8.3.1
openldap2-devel-static-2.4.33-8.3.1

- openSUSE 13.1 (x86_64):

libldap-2_4-2-32bit-2.4.33-8.3.1
libldap-2_4-2-debuginfo-32bit-2.4.33-8.3.1
openldap2-devel-32bit-2.4.33-8.3.1

- openSUSE 13.1 (noarch):

openldap2-doc-2.4.33-8.3.1


References:

https://www.suse.com/security/cve/CVE-2015-1545.html
https://www.suse.com/security/cve/CVE-2015-1546.html
https://bugzilla.suse.com/905959
https://bugzilla.suse.com/916897
https://bugzilla.suse.com/916914


< Previous Next >
This Thread
  • No further messages