Mailinglist Archive: opensuse-updates (71 mails)

< Previous Next >
openSUSE-SU-2015:1261-1: moderate: Security update for libidn
openSUSE Security Update: Security update for libidn
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1261-1
Rating: moderate
References: #923241
Cross-References: CVE-2015-2059
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

libidn was updated to version 1.31 to fix one security issue.

This security issue was fixed:
- CVE-2015-2059: Out-of-bounds read with stringprep on invalid UTF-8
(bsc#923241).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-497=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-497=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libidn-debugsource-1.31-3.3.1
libidn-devel-1.31-3.3.1
libidn-tools-1.31-3.3.1
libidn-tools-debuginfo-1.31-3.3.1
libidn11-1.31-3.3.1
libidn11-debuginfo-1.31-3.3.1

- openSUSE 13.2 (x86_64):

libidn11-32bit-1.31-3.3.1
libidn11-debuginfo-32bit-1.31-3.3.1

- openSUSE 13.1 (i586 x86_64):

libidn-debugsource-1.31-7.3.1
libidn-devel-1.31-7.3.1
libidn-tools-1.31-7.3.1
libidn-tools-debuginfo-1.31-7.3.1
libidn11-1.31-7.3.1
libidn11-debuginfo-1.31-7.3.1

- openSUSE 13.1 (x86_64):

libidn11-32bit-1.31-7.3.1
libidn11-debuginfo-32bit-1.31-7.3.1


References:

https://www.suse.com/security/cve/CVE-2015-2059.html
https://bugzilla.suse.com/923241


< Previous Next >
This Thread
  • No further messages