Mailinglist Archive: opensuse-updates (71 mails)

< Previous Next >
openSUSE-SU-2015:1244-1: moderate: Security update for cups-filters
openSUSE Security Update: Security update for cups-filters
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1244-1
Rating: moderate
References: #921753 #936281 #937018
Cross-References: CVE-2015-2265 CVE-2015-3258 CVE-2015-3279

Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

cups-filters was updated to fix three security issues.

These security issues were fixed:
- CVE-2015-2265: The remove_bad_chars function in utils/cups-browsed.c in
cups-filters before 1.0.66 allowed remote IPP printers to execute
arbitrary commands via consecutive shell metacharacters in the (1) model
or (2) PDL. NOTE: this vulnerability exists because of an incomplete fix
for CVE-2014-2707 (bsc#921753).
- CVE-2015-3279: Texttopdf integer overflow (incomplete fix for
CVE-2015-3258) (bsc#937018).
- CVE-2015-3258: Texttopdf heap-based buffer overflow (bsc#936281).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-492=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

cups-filters-1.0.58-2.7.1
cups-filters-cups-browsed-1.0.58-2.7.1
cups-filters-cups-browsed-debuginfo-1.0.58-2.7.1
cups-filters-debuginfo-1.0.58-2.7.1
cups-filters-debugsource-1.0.58-2.7.1
cups-filters-devel-1.0.58-2.7.1
cups-filters-foomatic-rip-1.0.58-2.7.1
cups-filters-foomatic-rip-debuginfo-1.0.58-2.7.1
cups-filters-ghostscript-1.0.58-2.7.1
cups-filters-ghostscript-debuginfo-1.0.58-2.7.1


References:

https://www.suse.com/security/cve/CVE-2015-2265.html
https://www.suse.com/security/cve/CVE-2015-3258.html
https://www.suse.com/security/cve/CVE-2015-3279.html
https://bugzilla.suse.com/921753
https://bugzilla.suse.com/936281
https://bugzilla.suse.com/937018


< Previous Next >
This Thread
  • No further messages