Mailinglist Archive: opensuse-updates (71 mails)

< Previous Next >
openSUSE-SU-2015:1162-1: moderate: Security update for p7zip
openSUSE Security Update: Security update for p7zip
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1162-1
Rating: moderate
References: #912878
Cross-References: CVE-2015-1038
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

p7zip was update to fix one security issue.

The following vulnerability was fixed:

* CVE-2015-1038: Attackers could have written to arbitrary files via a
symlink attack in a specially crafted archive (boo#912878)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-456=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-456=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

p7zip-9.20.1-12.3.1
p7zip-debuginfo-9.20.1-12.3.1
p7zip-debugsource-9.20.1-12.3.1

- openSUSE 13.1 (i586 x86_64):

p7zip-9.20.1-10.3.1
p7zip-debuginfo-9.20.1-10.3.1
p7zip-debugsource-9.20.1-10.3.1


References:

https://www.suse.com/security/cve/CVE-2015-1038.html
https://bugzilla.suse.com/912878


< Previous Next >
List Navigation
This Thread
  • No further messages