Mailinglist Archive: opensuse-updates (64 mails)

< Previous Next >
openSUSE-SU-2015:1082-1: moderate: Security update for strongswan
openSUSE Security Update: Security update for strongswan
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1082-1
Rating: moderate
References: #933591
Cross-References: CVE-2015-4171
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

strongswan was updated to fix a rogue servers vulnerability, that may
enable rogue servers able to authenticate itself with certificate issued
by any CA the client trusts, to gain user credentials from a client in
certain IKEv2 setups (bsc#933591,CVE-2015-4171).

More information can be found on
https://www.strongswan.org/blog/2015/06/08/strongswan-vulnerability-%28cve-
2015-4171%29.html


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-432=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-432=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

strongswan-5.1.3-4.11.1
strongswan-debugsource-5.1.3-4.11.1
strongswan-ipsec-5.1.3-4.11.1
strongswan-ipsec-debuginfo-5.1.3-4.11.1
strongswan-libs0-5.1.3-4.11.1
strongswan-libs0-debuginfo-5.1.3-4.11.1
strongswan-mysql-5.1.3-4.11.1
strongswan-mysql-debuginfo-5.1.3-4.11.1
strongswan-nm-5.1.3-4.11.1
strongswan-nm-debuginfo-5.1.3-4.11.1
strongswan-sqlite-5.1.3-4.11.1
strongswan-sqlite-debuginfo-5.1.3-4.11.1

- openSUSE 13.2 (noarch):

strongswan-doc-5.1.3-4.11.1

- openSUSE 13.1 (i586 x86_64):

strongswan-5.1.1-11.1
strongswan-debugsource-5.1.1-11.1
strongswan-ipsec-5.1.1-11.1
strongswan-ipsec-debuginfo-5.1.1-11.1
strongswan-libs0-5.1.1-11.1
strongswan-libs0-debuginfo-5.1.1-11.1
strongswan-mysql-5.1.1-11.1
strongswan-mysql-debuginfo-5.1.1-11.1
strongswan-nm-5.1.1-11.1
strongswan-nm-debuginfo-5.1.1-11.1
strongswan-sqlite-5.1.1-11.1
strongswan-sqlite-debuginfo-5.1.1-11.1

- openSUSE 13.1 (noarch):

strongswan-doc-5.1.1-11.1


References:

https://www.suse.com/security/cve/CVE-2015-4171.html
https://bugzilla.suse.com/933591


< Previous Next >
This Thread
  • No further messages