Mailinglist Archive: opensuse-updates (50 mails)

< Previous Next >
openSUSE-SU-2015:0857-1: moderate: Security update for dnsmasq
openSUSE Security Update: Security update for dnsmasq
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0857-1
Rating: moderate
References: #928867
Cross-References: CVE-2015-3294
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

The DNS server dnsmasq was updated to fix one security issue.

The following vulnerability was fixed:

* CVE-2015-3294: A remote unauthenticated attacker could have caused a
denial of service (DoS) or read heap memory, potentially disclosing
information such as performed DNS queries or encryption keys.
(bsc#928867)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-359=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-359=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

dnsmasq-2.71-3.4.1
dnsmasq-debuginfo-2.71-3.4.1
dnsmasq-debugsource-2.71-3.4.1
dnsmasq-utils-2.71-3.4.1
dnsmasq-utils-debuginfo-2.71-3.4.1

- openSUSE 13.1 (i586 x86_64):

dnsmasq-2.65-7.3.1
dnsmasq-debuginfo-2.65-7.3.1
dnsmasq-debugsource-2.65-7.3.1
dnsmasq-utils-2.65-7.3.1
dnsmasq-utils-debuginfo-2.65-7.3.1


References:

https://www.suse.com/security/cve/CVE-2015-3294.html
https://bugzilla.suse.com/928867


< Previous Next >
This Thread
  • No further messages