Mailinglist Archive: opensuse-updates (61 mails)

< Previous Next >
openSUSE-SU-2015:0724-1: moderate: Security update for rubygem-rest-client
openSUSE Security Update: Security update for rubygem-rest-client
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0724-1
Rating: moderate
References: #917802
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

rubygem-rest-client was updated to fix one security issue.

The following vulnerability was fixed:

- Application logging of password information in plaintext could have
allowed a local attacker to gain access to this information (bnc#917802)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-307=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-307=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

rubygem-rest-client-1.6.7-7.3.1
rubygem-rest-client-doc-1.6.7-7.3.1
rubygem-rest-client-testsuite-1.6.7-7.3.1

- openSUSE 13.1 (i586 x86_64):

rubygem-rest-client-1.6.7-4.3.1
rubygem-rest-client-doc-1.6.7-4.3.1
rubygem-rest-client-testsuite-1.6.7-4.3.1


References:

https://bugzilla.suse.com/917802


< Previous Next >
This Thread
  • No further messages