Mailinglist Archive: opensuse-updates (61 mails)

< Previous Next >
openSUSE-SU-2015:0685-1: Security update for potrace
openSUSE Security Update: Security update for potrace
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0685-1
Rating: low
References: #924904
Cross-References: CVE-2013-7437
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

The bitmap to vector graphic tracing utility potrace was updated to fix
one security issue.

The following vulnerability was fixed:

- Very large bitmaps could trigger a buffer overflow, crashing the program
and causing denial of service (bsc#924904, CVE-2013-7437)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-297=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-297=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libpotrace0-1.11-4.4.1
libpotrace0-debuginfo-1.11-4.4.1
potrace-1.11-4.4.1
potrace-debuginfo-1.11-4.4.1
potrace-debugsource-1.11-4.4.1
potrace-devel-1.11-4.4.1

- openSUSE 13.1 (i586 x86_64):

libpotrace0-1.11-2.4.1
libpotrace0-debuginfo-1.11-2.4.1
potrace-1.11-2.4.1
potrace-debuginfo-1.11-2.4.1
potrace-debugsource-1.11-2.4.1
potrace-devel-1.11-2.4.1


References:

https://www.suse.com/security/cve/CVE-2013-7437.html
https://bugzilla.suse.com/924904


< Previous Next >
This Thread
  • No further messages