Mailinglist Archive: opensuse-updates (98 mails)

< Previous Next >
openSUSE-RU-2015:0520-1: moderate: Recommended update for libass
openSUSE Recommended Update: Recommended update for libass
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:0520-1
Rating: moderate
References: #921212
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This recommended update for libass fixes the following issues:
- Update from version 0.10.2 to 0.12.1 (boo#921212)
+ Make ASS drawings with an extremely high number of control points
work. This change increases compatibility with VSFilter.
+ Bugfixes
* Fix a crash when using newer harfbuzz versions
* Load embedded memory fonts correctly
* Large shadow offsets rendered incorrectly
* Fix incorrect closing of last drawing contour
* Fix issues with undefined behavior in shifts
* Lots of of malloc() error checking


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-237=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libass-debugsource-0.12.1-2.5.1
libass-devel-0.12.1-2.5.1
libass5-0.12.1-2.5.1
libass5-debuginfo-0.12.1-2.5.1

- openSUSE 13.2 (x86_64):

libass5-32bit-0.12.1-2.5.1
libass5-debuginfo-32bit-0.12.1-2.5.1


References:

https://bugzilla.suse.com/921212


< Previous Next >
This Thread
  • No further messages