Mailinglist Archive: opensuse-updates (98 mails)

< Previous Next >
openSUSE-SU-2015:0414-1: moderate: Security update for postgresql93
openSUSE Security Update: Security update for postgresql93
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0414-1
Rating: moderate
References: #916953
Cross-References: CVE-2014-8161 CVE-2015-0241 CVE-2015-0243
CVE-2015-0244
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

postgresql93 was updated to version 9.3.6 to fix four security issues.

These security issues were fixed:
- CVE-2015-0241: Fix buffer overruns in to_char() (bnc#916953).
- CVE-2015-0243: Fix buffer overruns in contrib/pgcrypto (bnc#916953).
- CVE-2015-0244: Fix possible loss of frontend/backend protocol
synchronization after an error (bnc#916953).
- CVE-2014-8161: Fix information leak via constraint-violation error
messages (bnc#916953).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-189=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libecpg6-9.3.6-2.4.1
libecpg6-debuginfo-9.3.6-2.4.1
libpq5-9.3.6-2.4.1
libpq5-debuginfo-9.3.6-2.4.1
postgresql93-9.3.6-2.4.1
postgresql93-contrib-9.3.6-2.4.1
postgresql93-contrib-debuginfo-9.3.6-2.4.1
postgresql93-debuginfo-9.3.6-2.4.1
postgresql93-debugsource-9.3.6-2.4.1
postgresql93-devel-9.3.6-2.4.1
postgresql93-devel-debuginfo-9.3.6-2.4.1
postgresql93-libs-debugsource-9.3.6-2.4.1
postgresql93-plperl-9.3.6-2.4.1
postgresql93-plperl-debuginfo-9.3.6-2.4.1
postgresql93-plpython-9.3.6-2.4.1
postgresql93-plpython-debuginfo-9.3.6-2.4.1
postgresql93-pltcl-9.3.6-2.4.1
postgresql93-pltcl-debuginfo-9.3.6-2.4.1
postgresql93-server-9.3.6-2.4.1
postgresql93-server-debuginfo-9.3.6-2.4.1
postgresql93-test-9.3.6-2.4.1

- openSUSE 13.2 (x86_64):

libecpg6-32bit-9.3.6-2.4.1
libecpg6-debuginfo-32bit-9.3.6-2.4.1
libpq5-32bit-9.3.6-2.4.1
libpq5-debuginfo-32bit-9.3.6-2.4.1

- openSUSE 13.2 (noarch):

postgresql93-docs-9.3.6-2.4.1


References:

http://support.novell.com/security/cve/CVE-2014-8161.html
http://support.novell.com/security/cve/CVE-2015-0241.html
http://support.novell.com/security/cve/CVE-2015-0243.html
http://support.novell.com/security/cve/CVE-2015-0244.html
https://bugzilla.suse.com/916953


< Previous Next >
This Thread
  • No further messages