Mailinglist Archive: opensuse-updates (89 mails)

< Previous Next >
openSUSE-RU-2015:0056-1: librevenge
openSUSE Recommended Update: librevenge
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:0056-1
Rating: low
References:
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that has 0 recommended fixes can now be installed.

Description:

This recommended update for librevenge fixes the following issues:
- Version bump to 0.0.2:
+ Better handling of invalid input in RVNGDirectoryStream functions.
+ Add documentation for RVNGDirectoryStream.
+ Add text:outline-level to allowed paragraph properties. This is to
allow import libraries to handle headings properly.
+ Properly handle units in all generators, instead of expecting
everything is in inches.
+ Implement open/closeGroup for RVNGSVGDrawingGenerator.
+ Improve handling of layers in RVNGSVGPresentationGenerator.
+ Handle master pages in RVNGSVGDrawingGenerator and
RVNGSVGPresentationGenerator.
+ Simple handling of tables in RVNGSVGDrawingGenerator and
RVNGSVGPresentationGenerator: just create a text box for each cell.
+ Fix return value of RVNGStringStream::seek when seeking to end.
+ Fix some warnings found by Coverity
+ Use symbol visibility on Linux. The library only exports public
functions now.
+ Fix several crashes or hangs when reading broken OLE2 or Zip files,
found with the help of american-fuzzy-lop.
+ Add fo:language, fo:country and fo:script to allowed span properties.
+ Handle headings in RVNGHTMLTextGenerator


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-27

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

librevenge-0_0-0-0.0.2-3.4.1
librevenge-0_0-0-debuginfo-0.0.2-3.4.1
librevenge-debugsource-0.0.2-3.4.1
librevenge-devel-0.0.2-3.4.1
librevenge-generators-0_0-0-0.0.2-3.4.1
librevenge-generators-0_0-0-debuginfo-0.0.2-3.4.1
librevenge-stream-0_0-0-0.0.2-3.4.1
librevenge-stream-0_0-0-debuginfo-0.0.2-3.4.1

- openSUSE 13.2 (noarch):

librevenge-doc-0.0.2-3.4.1


References:



< Previous Next >
This Thread
  • No further messages