Mailinglist Archive: opensuse-updates (89 mails)

< Previous Next >
openSUSE-SU-2015:0002-1: moderate: Security update for ruby20
openSUSE Security Update: Security update for ruby20
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0002-1
Rating: moderate
References: #902851 #905326
Cross-References: CVE-2014-8080 CVE-2014-8090
Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This ruby update fixes the following two security issues:

- bnc#902851: fix CVE-2014-8080: Denial Of Service XML Expansion
- bnc#905326: fix CVE-2014-8090: Another Denial Of Service XML Expansion
- Enable tests to run during the build. This way we can compare the
results on different builds.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

ruby20-2.0.0.p247-3.19.1
ruby20-debuginfo-2.0.0.p247-3.19.1
ruby20-debugsource-2.0.0.p247-3.19.1
ruby20-devel-2.0.0.p247-3.19.1
ruby20-devel-extra-2.0.0.p247-3.19.1
ruby20-tk-2.0.0.p247-3.19.1
ruby20-tk-debuginfo-2.0.0.p247-3.19.1

- openSUSE 13.1 (noarch):

ruby20-doc-ri-2.0.0.p247-3.19.1


References:

http://support.novell.com/security/cve/CVE-2014-8080.html
http://support.novell.com/security/cve/CVE-2014-8090.html
https://bugzilla.suse.com/show_bug.cgi?id=902851
https://bugzilla.suse.com/show_bug.cgi?id=905326


< Previous Next >
List Navigation
This Thread
  • No further messages