Mailinglist Archive: opensuse-updates (114 mails)

< Previous Next >
openSUSE-SU-2014:1515-1: moderate: Security update for rubygem-actionpack-3_2
openSUSE Security Update: Security update for rubygem-actionpack-3_2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1515-1
Rating: moderate
References: #903662 #905727
Cross-References: CVE-2014-7818 CVE-2014-7829
Affected Products:
openSUSE 13.2
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

rubygem-actionpack-3_2 was updated to fix two security issues.

These security issues were fixed:
- Arbitrary file existence disclosure (CVE-2014-7829).
- Arbitrary file existence disclosure (CVE-2014-7818).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2014-724

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-724

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-724

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

rubygem-actionpack-3_2-3.2.17-3.4.1
rubygem-actionpack-3_2-doc-3.2.17-3.4.1

- openSUSE 13.1 (i586 x86_64):

rubygem-actionpack-3_2-3.2.13-2.28.1
rubygem-actionpack-3_2-doc-3.2.13-2.28.1

- openSUSE 12.3 (i586 x86_64):

rubygem-actionpack-3_2-3.2.12-1.32.1
rubygem-actionpack-3_2-doc-3.2.12-1.32.1


References:

http://support.novell.com/security/cve/CVE-2014-7818.html
http://support.novell.com/security/cve/CVE-2014-7829.html
https://bugzilla.suse.com/show_bug.cgi?id=903662
https://bugzilla.suse.com/show_bug.cgi?id=905727


< Previous Next >
This Thread
  • No further messages