Mailinglist Archive: opensuse-updates (64 mails)

< Previous Next >
openSUSE-SU-2014:1145-1: moderate: lua
openSUSE Security Update: lua
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1145-1
Rating: moderate
References: #893824
Cross-References: CVE-2014-5461
Affected Products:
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

lua was updated to fix an overflow in varargs functions (CVE-2014-5461
,bnc#893824)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-549

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-549

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

liblua5_2-5.2.2-2.4.1
liblua5_2-debuginfo-5.2.2-2.4.1
lua-5.2.2-2.4.1
lua-debuginfo-5.2.2-2.4.1
lua-debugsource-5.2.2-2.4.1
lua-devel-5.2.2-2.4.1

- openSUSE 13.1 (x86_64):

liblua5_2-32bit-5.2.2-2.4.1
liblua5_2-debuginfo-32bit-5.2.2-2.4.1

- openSUSE 13.1 (noarch):

lua-doc-5.2.2-2.4.1

- openSUSE 12.3 (i586 x86_64):

liblua5_2-5.2.1-2.5.1
liblua5_2-debuginfo-5.2.1-2.5.1
lua-5.2.1-2.5.1
lua-debuginfo-5.2.1-2.5.1
lua-debugsource-5.2.1-2.5.1
lua-devel-5.2.1-2.5.1

- openSUSE 12.3 (x86_64):

liblua5_2-32bit-5.2.1-2.5.1
liblua5_2-debuginfo-32bit-5.2.1-2.5.1

- openSUSE 12.3 (noarch):

lua-doc-5.2.1-2.5.1


References:

http://support.novell.com/security/cve/CVE-2014-5461.html
https://bugzilla.novell.com/893824


< Previous Next >
This Thread
  • No further messages