Mailinglist Archive: opensuse-updates (102 mails)

< Previous Next >
openSUSE-SU-2014:0368-1: moderate: postgresql: updates to 9.0.16 security release
openSUSE Security Update: postgresql: updates to 9.0.16 security release
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0368-1
Rating: moderate
References: #864845 #864846 #864847 #864850 #864851 #864852
#864853
Cross-References: CVE-2014-0060 CVE-2014-0061 CVE-2014-0062
CVE-2014-0063 CVE-2014-0064 CVE-2014-0065
CVE-2014-0066 CVE-2014-0067
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes 8 vulnerabilities is now available.

Description:

- Security and bugfix release 9.0.16:
*Shore up GRANT ... WITH ADMIN OPTION restrictions
(CVE-2014-0060)
*Prevent privilege escalation via manual calls to PL
validator functions (CVE-2014-0061)
*Avoid multiple name lookups during table and index DDL
(CVE-2014-0062)
*Prevent buffer overrun with long datetime strings
(CVE-2014-0063)
*Prevent buffer overrun due to integer overflow in size
calculations (CVE-2014-0064)
*Prevent overruns of fixed-size buffers (CVE-2014-0065)
*Avoid crashing if crypt() returns NULL (CVE-2014-0066)
*Document risks of make check in the regression testing
instructions (CVE-2014-0067)
- for details see:
http://www.postgresql.org/docs/9.0/static/release-9-0-16.htm
l


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch 2014-32

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

libecpg6-9.0.16-43.1
libecpg6-debuginfo-9.0.16-43.1
libpq5-9.0.16-43.1
libpq5-debuginfo-9.0.16-43.1
postgresql-9.0.16-43.1
postgresql-contrib-9.0.16-43.1
postgresql-contrib-debuginfo-9.0.16-43.1
postgresql-debuginfo-9.0.16-43.1
postgresql-debugsource-9.0.16-43.1
postgresql-devel-9.0.16-43.1
postgresql-devel-debuginfo-9.0.16-43.1
postgresql-libs-debugsource-9.0.16-43.1
postgresql-plperl-9.0.16-43.1
postgresql-plperl-debuginfo-9.0.16-43.1
postgresql-plpython-9.0.16-43.1
postgresql-plpython-debuginfo-9.0.16-43.1
postgresql-pltcl-9.0.16-43.1
postgresql-pltcl-debuginfo-9.0.16-43.1
postgresql-server-9.0.16-43.1
postgresql-server-debuginfo-9.0.16-43.1

- openSUSE 11.4 (x86_64):

libpq5-32bit-9.0.16-43.1
libpq5-debuginfo-32bit-9.0.16-43.1

- openSUSE 11.4 (noarch):

postgresql-docs-9.0.16-43.1

- openSUSE 11.4 (ia64):

libpq5-debuginfo-x86-9.0.16-43.1
libpq5-x86-9.0.16-43.1


References:

http://support.novell.com/security/cve/CVE-2014-0060.html
http://support.novell.com/security/cve/CVE-2014-0061.html
http://support.novell.com/security/cve/CVE-2014-0062.html
http://support.novell.com/security/cve/CVE-2014-0063.html
http://support.novell.com/security/cve/CVE-2014-0064.html
http://support.novell.com/security/cve/CVE-2014-0065.html
http://support.novell.com/security/cve/CVE-2014-0066.html
http://support.novell.com/security/cve/CVE-2014-0067.html
https://bugzilla.novell.com/864845
https://bugzilla.novell.com/864846
https://bugzilla.novell.com/864847
https://bugzilla.novell.com/864850
https://bugzilla.novell.com/864851
https://bugzilla.novell.com/864852
https://bugzilla.novell.com/864853


< Previous Next >
This Thread
  • No further messages