Mailinglist Archive: opensuse-updates (120 mails)

< Previous Next >
openSUSE-RU-2013:1725-1: subversion: update to 1.8.4
openSUSE Recommended Update: subversion: update to 1.8.4
______________________________________________________________________________

Announcement ID: openSUSE-RU-2013:1725-1
Rating: low
References: #847103
Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This update fixes the following issues with subversion:
- bnc#847103: update to 1.8.4
+ Client- and server-side bugfixes:
* fix assertion on urls of the form 'file://./'
* translation updates for Swedish
+ Client-side bugfixes:
* revert: fix problems reverting moves
* update: fix assertion when file external access is
denied
* merge: reduce network connections for automatic merge
* merge: fix path corruption during reintegration
* mergeinfo: fix crash
* ra_serf: verify the result of xml parsing
* ra_serf: improve error messages during commit
* ra_local: fix error with repository in Windows drive
root
* fix crash on windows when piped command is interrupted
* fix assertion when upgrading old working copies
+ Server-side bugfixes:
* hotcopy: cleanup unpacked revprops with
'--incremental'
* fix OOM on concurrent requests at threaded server
start
* fsfs: improve error message when unsupported fsfs
format found
* fix memory problem in 3rd party FS module loader
+ Developer-visible changes - Bindings:
* javahl: canonicalize path for streaFileContent method

- packaging changes:
+ update keyring


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2013-874

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

libsvn_auth_gnome_keyring-1-0-1.8.4-2.4.1
libsvn_auth_gnome_keyring-1-0-debuginfo-1.8.4-2.4.1
libsvn_auth_kwallet-1-0-1.8.4-2.4.1
libsvn_auth_kwallet-1-0-debuginfo-1.8.4-2.4.1
subversion-1.8.4-2.4.1
subversion-debuginfo-1.8.4-2.4.1
subversion-debugsource-1.8.4-2.4.1
subversion-devel-1.8.4-2.4.1
subversion-perl-1.8.4-2.4.1
subversion-perl-debuginfo-1.8.4-2.4.1
subversion-python-1.8.4-2.4.1
subversion-python-debuginfo-1.8.4-2.4.1
subversion-ruby-1.8.4-2.4.1
subversion-ruby-debuginfo-1.8.4-2.4.1
subversion-server-1.8.4-2.4.1
subversion-server-debuginfo-1.8.4-2.4.1
subversion-tools-1.8.4-2.4.1
subversion-tools-debuginfo-1.8.4-2.4.1

- openSUSE 13.1 (noarch):

subversion-bash-completion-1.8.4-2.4.1


References:

https://bugzilla.novell.com/847103


< Previous Next >
This Thread
  • No further messages