Mailinglist Archive: opensuse-updates (96 mails)

< Previous Next >
openSUSE-RU-2013:1274-1: pgadmin3: Update to version 1.16.1 which supports the current version of PostgreSQL
openSUSE Recommended Update: pgadmin3: Update to version 1.16.1 which
supports the current version of PostgreSQL
______________________________________________________________________________

Announcement ID: openSUSE-RU-2013:1274-1
Rating: low
References: #800831
Affected Products:
openSUSE 12.3
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This update fixes the following issues with pgadmin3:
- bnc#800831:
+ Update to 1.16.1
* Prevent a crash that could happen if further changes
were made on a dialogue after using the Apply button.
* Save new comments on already existing columns when
editing a table.
* Fix the query editor behaviour when executing COPY TO
stdout and COPY FROM stdin.
* Date picker controls returns a full timestamp by
default, which can cause inadvertent date changes on jobs
and role validty dates. Ignore the time part.
* Fix query for database descriptions
* Avoid querying the catalogs for toast table settings
for every table in the database. This gives a huge
performance gain with large schemas.
* Prevent a crash when refreshing a node which has a
child with an open dialogue
* Fix dropping/renaming of indexes
* Avoid updating the GQB model on every key press in
the query tool
* Fix a crash that can occur when renaming objects.
* Fix dropping of constraints
* Fix the "blocked by" column in the server status
dialogue on 9.2 servers
* Prevent a crash if the query tool is closed whilst a
file is loading
* Fix setting of comments on PPAS procedures.
* Don't autosize the search results columns if no
results are found
* Prevent a crash if opening a second config file in
the editor.
* Prevent the SSL options combo box displaying
duplicate options if the server dialogue is reopened
* Fix trigger query when connected to PostgreSQL 8.2 or
lower
* Fix message when executing an empty query
* Add privilege support on aggregates.
* Add inline function support on languages.
* Add support for range types.
* Add support for setting db/user config on dlgRole.
* Move references table textbox to the third tab in
dlgForeignKey.
* Support for the new two columns in 9.2
pg_stat_database
* Support for renaming constraints (9.2).
* Fix wxWidgets 2.9 compatibility with pgAdmin on Linux
* New import tool.
* Support for the LEAKPROOF option in functions.
* Support ANALYZE, CATEGORY, and PREFERED items for
CREATE TYPE statement.
* Support CREATE TABLE LIKE.
* Support for the new TIMING option in EXPLAIN ANALYZE.
* Support for the new three columns in 9.2
pg_stat_database
* Use date_trunc to skip the microseconds part of all
timestamp fields in frmStatus.
* Support new/changed pg_stat_activity fields.
* Allow renaming a domain.
* Add subitems to the schemas and catalogs in GQB.
* Support section options for pg_dump/pg_restore.
* Add security_barrier option handling for views.
* Add an "New Folder" button to the "Add Favourite"
dialog in the query tool
* Support for the new sslcompression connection option.
* Add renaming of FDW and Server objects.
* Support for TRUNCATE permission
* Reverse engineering in the database designer.
* Highlight the other brace even if the current one is
before the caret
* Add options to refresh objects automatically when
clicked
* Redesign frmOptions.
* Prevents dropping connection, dropping or refreshing
object when a properties dialog is open.
* Support for multimodels diagram in the database
designer.
* Implement enable/disable save button, on text change.
* Change doc build system.
* Support for security labels on global/shared objects
(9.2 feature).
* Support for security labels on local objects (9.1
feature).
* Support for non valid domains, and check constraints
(9.2 feature).
* Add load/save support for the Database Designer.
* Allow change of schema in the UI.
* Add "Search Objects" dialog.
* New maintenance action: CLUSTER.
* Enable "Has OIDs" on 8.4+ even when the table is
already created
* Add Database Designer.
* Allow change of the fill factor.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-617

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

pgadmin3-1.16.1-2.4.1
pgadmin3-debuginfo-1.16.1-2.4.1

- openSUSE 12.3 (noarch):

pgadmin3-lang-1.16.1-2.4.1


References:

https://bugzilla.novell.com/800831


< Previous Next >
This Thread
  • No further messages