Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2013:0614-1: ruby: update to fix XML security problems
openSUSE Security Update: ruby: update to fix XML security problems
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0614-1
Rating: low
References: #808137
Cross-References: CVE-2013-1821
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

Ruby was updated to fix a XML entity expansion denial of
service attack (CVE-2013-1821)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch 2013-54

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

ruby-1.8.7.p357-0.32.1
ruby-debuginfo-1.8.7.p357-0.32.1
ruby-debugsource-1.8.7.p357-0.32.1
ruby-devel-1.8.7.p357-0.32.1
ruby-examples-1.8.7.p357-0.32.1
ruby-test-suite-1.8.7.p357-0.32.1
ruby-tk-1.8.7.p357-0.32.1
ruby-tk-debuginfo-1.8.7.p357-0.32.1

- openSUSE 11.4 (noarch):

ruby-doc-html-1.8.7.p357-0.32.1
ruby-doc-ri-1.8.7.p357-0.32.1


References:

http://support.novell.com/security/cve/CVE-2013-1821.html
https://bugzilla.novell.com/808137


< Previous Next >
This Thread
  • No further messages