Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2013:0535-1: moderate: ImageMagick: integer overflow fixes
openSUSE Security Update: ImageMagick: integer overflow fixes
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0535-1
Rating: moderate
References: #773612
Cross-References: CVE-2012-3437
Affected Products:
openSUSE 12.3
openSUSE 12.2
openSUSE 12.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


ImageMagick received fixes for a overflow in *png_malloc
functions. (CVE-2012-3437)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-251

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-251

- openSUSE 12.1:

zypper in -t patch openSUSE-2013-251

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

ImageMagick-6.7.8.8-4.5.1
ImageMagick-debuginfo-6.7.8.8-4.5.1
ImageMagick-debugsource-6.7.8.8-4.5.1
ImageMagick-devel-6.7.8.8-4.5.1
ImageMagick-extra-6.7.8.8-4.5.1
ImageMagick-extra-debuginfo-6.7.8.8-4.5.1
libMagick++-devel-6.7.8.8-4.5.1
libMagick++5-6.7.8.8-4.5.1
libMagick++5-debuginfo-6.7.8.8-4.5.1
libMagickCore5-6.7.8.8-4.5.1
libMagickCore5-debuginfo-6.7.8.8-4.5.1
libMagickWand5-6.7.8.8-4.5.1
libMagickWand5-debuginfo-6.7.8.8-4.5.1
perl-PerlMagick-6.7.8.8-4.5.1
perl-PerlMagick-debuginfo-6.7.8.8-4.5.1

- openSUSE 12.3 (x86_64):

ImageMagick-devel-32bit-6.7.8.8-4.5.1
libMagickCore5-32bit-6.7.8.8-4.5.1
libMagickCore5-debuginfo-32bit-6.7.8.8-4.5.1
libMagickWand5-32bit-6.7.8.8-4.5.1
libMagickWand5-debuginfo-32bit-6.7.8.8-4.5.1

- openSUSE 12.3 (noarch):

ImageMagick-doc-6.7.8.8-4.5.1

- openSUSE 12.2 (i586 x86_64):

ImageMagick-6.7.6.9-2.4.1
ImageMagick-debuginfo-6.7.6.9-2.4.1
ImageMagick-debugsource-6.7.6.9-2.4.1
ImageMagick-devel-6.7.6.9-2.4.1
ImageMagick-extra-6.7.6.9-2.4.1
ImageMagick-extra-debuginfo-6.7.6.9-2.4.1
libMagick++-devel-6.7.6.9-2.4.1
libMagick++5-6.7.6.9-2.4.1
libMagick++5-debuginfo-6.7.6.9-2.4.1
libMagickCore5-6.7.6.9-2.4.1
libMagickCore5-debuginfo-6.7.6.9-2.4.1
libMagickWand5-6.7.6.9-2.4.1
libMagickWand5-debuginfo-6.7.6.9-2.4.1
perl-PerlMagick-6.7.6.9-2.4.1
perl-PerlMagick-debuginfo-6.7.6.9-2.4.1

- openSUSE 12.2 (x86_64):

ImageMagick-devel-32bit-6.7.6.9-2.4.1
libMagickCore5-32bit-6.7.6.9-2.4.1
libMagickCore5-debuginfo-32bit-6.7.6.9-2.4.1
libMagickWand5-32bit-6.7.6.9-2.4.1
libMagickWand5-debuginfo-32bit-6.7.6.9-2.4.1

- openSUSE 12.2 (noarch):

ImageMagick-doc-6.7.6.9-2.4.1

- openSUSE 12.1 (i586 x86_64):

ImageMagick-6.7.2.7-5.8.1
ImageMagick-debuginfo-6.7.2.7-5.8.1
ImageMagick-debugsource-6.7.2.7-5.8.1
ImageMagick-devel-6.7.2.7-5.8.1
ImageMagick-extra-6.7.2.7-5.8.1
ImageMagick-extra-debuginfo-6.7.2.7-5.8.1
libMagick++-devel-6.7.2.7-5.8.1
libMagick++5-6.7.2.7-5.8.1
libMagick++5-debuginfo-6.7.2.7-5.8.1
libMagickCore5-6.7.2.7-5.8.1
libMagickCore5-debuginfo-6.7.2.7-5.8.1
libMagickWand5-6.7.2.7-5.8.1
libMagickWand5-debuginfo-6.7.2.7-5.8.1
perl-PerlMagick-6.7.2.7-5.8.1
perl-PerlMagick-debuginfo-6.7.2.7-5.8.1

- openSUSE 12.1 (x86_64):

ImageMagick-devel-32bit-6.7.2.7-5.8.1
libMagickCore5-32bit-6.7.2.7-5.8.1
libMagickCore5-debuginfo-32bit-6.7.2.7-5.8.1
libMagickWand5-32bit-6.7.2.7-5.8.1
libMagickWand5-debuginfo-32bit-6.7.2.7-5.8.1

- openSUSE 12.1 (noarch):

ImageMagick-doc-6.7.2.7-5.8.1

- openSUSE 12.1 (ia64):

libMagickCore5-debuginfo-x86-6.7.2.7-5.8.1
libMagickCore5-x86-6.7.2.7-5.8.1
libMagickWand5-debuginfo-x86-6.7.2.7-5.8.1
libMagickWand5-x86-6.7.2.7-5.8.1


References:

http://support.novell.com/security/cve/CVE-2012-3437.html
https://bugzilla.novell.com/773612


< Previous Next >
This Thread
  • No further messages