Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2013:0498-1: moderate: krb5: security fixes for PKINIT plugin
openSUSE Security Update: krb5: security fixes for PKINIT plugin
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0498-1
Rating: moderate
References: #794784 #806715 #807556
Cross-References: CVE-2012-1016 CVE-2013-1415
Affected Products:
openSUSE 12.3
openSUSE 12.2
openSUSE 12.1
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:


krb5 was updated to fix security issues in PKINIT:

- fix PKINIT null pointer deref in pkinit_check_kdc_pkid()
(CVE-2012-1016 bnc#807556)

- fix PKINIT null pointer deref (CVE-2013-1415 bnc#806715)

Also package a missing file on 12.3 (bnc#794784).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-224

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-224

- openSUSE 12.1:

zypper in -t patch openSUSE-2013-224

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

krb5-1.10.2-10.5.1
krb5-client-1.10.2-10.5.1
krb5-client-debuginfo-1.10.2-10.5.1
krb5-debuginfo-1.10.2-10.5.1
krb5-debugsource-1.10.2-10.5.1
krb5-devel-1.10.2-10.5.1
krb5-mini-1.10.2-10.5.1
krb5-mini-debuginfo-1.10.2-10.5.1
krb5-mini-debugsource-1.10.2-10.5.1
krb5-mini-devel-1.10.2-10.5.1
krb5-plugin-kdb-ldap-1.10.2-10.5.1
krb5-plugin-kdb-ldap-debuginfo-1.10.2-10.5.1
krb5-plugin-preauth-pkinit-1.10.2-10.5.1
krb5-plugin-preauth-pkinit-debuginfo-1.10.2-10.5.1
krb5-server-1.10.2-10.5.1
krb5-server-debuginfo-1.10.2-10.5.1

- openSUSE 12.3 (x86_64):

krb5-32bit-1.10.2-10.5.1
krb5-debuginfo-32bit-1.10.2-10.5.1
krb5-devel-32bit-1.10.2-10.5.1

- openSUSE 12.3 (noarch):

krb5-doc-1.10.2-10.5.2

- openSUSE 12.2 (i586 x86_64):

krb5-1.10.2-3.12.1
krb5-client-1.10.2-3.12.1
krb5-client-debuginfo-1.10.2-3.12.1
krb5-debuginfo-1.10.2-3.12.1
krb5-debugsource-1.10.2-3.12.1
krb5-devel-1.10.2-3.12.1
krb5-mini-1.10.2-3.12.1
krb5-mini-debuginfo-1.10.2-3.12.1
krb5-mini-debugsource-1.10.2-3.12.1
krb5-mini-devel-1.10.2-3.12.1
krb5-plugin-kdb-ldap-1.10.2-3.12.1
krb5-plugin-kdb-ldap-debuginfo-1.10.2-3.12.1
krb5-plugin-preauth-pkinit-1.10.2-3.12.1
krb5-plugin-preauth-pkinit-debuginfo-1.10.2-3.12.1
krb5-server-1.10.2-3.12.1
krb5-server-debuginfo-1.10.2-3.12.1

- openSUSE 12.2 (x86_64):

krb5-32bit-1.10.2-3.12.1
krb5-debuginfo-32bit-1.10.2-3.12.1
krb5-devel-32bit-1.10.2-3.12.1

- openSUSE 12.2 (noarch):

krb5-doc-1.10.2-3.12.3

- openSUSE 12.1 (i586 x86_64):

krb5-1.9.1-24.16.1
krb5-client-1.9.1-24.16.1
krb5-client-debuginfo-1.9.1-24.16.1
krb5-debuginfo-1.9.1-24.16.1
krb5-debugsource-1.9.1-24.16.1
krb5-devel-1.9.1-24.16.1
krb5-plugin-kdb-ldap-1.9.1-24.16.1
krb5-plugin-kdb-ldap-debuginfo-1.9.1-24.16.1
krb5-plugin-preauth-pkinit-1.9.1-24.16.1
krb5-plugin-preauth-pkinit-debuginfo-1.9.1-24.16.1
krb5-server-1.9.1-24.16.1
krb5-server-debuginfo-1.9.1-24.16.1

- openSUSE 12.1 (x86_64):

krb5-32bit-1.9.1-24.16.1
krb5-debuginfo-32bit-1.9.1-24.16.1
krb5-devel-32bit-1.9.1-24.16.1

- openSUSE 12.1 (ia64):

krb5-debuginfo-x86-1.9.1-24.16.1
krb5-x86-1.9.1-24.16.1


References:

http://support.novell.com/security/cve/CVE-2012-1016.html
http://support.novell.com/security/cve/CVE-2013-1415.html
https://bugzilla.novell.com/794784
https://bugzilla.novell.com/806715
https://bugzilla.novell.com/807556


< Previous Next >
This Thread
  • No further messages