Mailinglist Archive: opensuse-updates (39 mails)

< Previous Next >
openSUSE-RU-2012:0401-1: moderate: update for postfix
openSUSE Recommended Update: update for postfix
______________________________________________________________________________

Announcement ID: openSUSE-RU-2012:0401-1
Rating: moderate
References: #743369
Affected Products:
openSUSE 12.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

- rcpostfix now updates the aliases too

- update to 2.8.8 Bugfixes: tlsproxy(8) stored TLS sessions
with a serverID of "tlsproxy" instead of "smtpd", wasting
an opportunity for session reuse. File:
tlsproxy/tlsproxy.c. missing lookup table entry and
terminator, causing proxymap server segfault when
postscreen(8) or verify(8) attempted to access their
cache via the proxymap server. This could never have
worked anyway, because the Postfix 2.8 proxymap protocol
does not support cache cleanup. File util/dict.c. the
Postfix client sqlite quoting routine returned the
unquoted result instead of the quoted text. The
opportunities for misuse are limited, because Postfix
sqlite files are usually owned by root, and Postfix
daemons usually run with non-root privileges so they
can't corrupt the database. Problem reported by Rob McGee
(rob0). File: global/dict_sqlite.c. the trace service
did not distinguish between notifications for a
non-bounce or a bounce message. This code pre-dates DSN
support and should have been updated when it was
re-purposed to handle DSN SUCCESS notifications. Problem
reported by Sabahattin Gucukoglu. File:
bounce/bounce_trace_service.c.
- use latest VDA patch (2.8.5)

- bnc#743369 - yast2 mail module does not open the firewall
- Set MD5DIR in SuSEconfig.postfix to avoid warnings

- bnc738693 - upgrade from 11.4 enables mysql service for
systemd


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-171

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.1 (i586 x86_64):

postfix-2.8.8-3.10.1
postfix-debuginfo-2.8.8-3.10.1
postfix-debugsource-2.8.8-3.10.1
postfix-devel-2.8.8-3.10.1
postfix-mysql-2.8.8-3.10.1
postfix-mysql-debuginfo-2.8.8-3.10.1
postfix-postgresql-2.8.8-3.10.1
postfix-postgresql-debuginfo-2.8.8-3.10.1

- openSUSE 12.1 (noarch):

postfix-doc-2.8.8-3.10.1


References:

https://bugzilla.novell.com/743369


< Previous Next >
This Thread
  • No further messages